Bug 1733935 - Open fd heal should filter O_APPEND/O_EXCL
Summary: Open fd heal should filter O_APPEND/O_EXCL
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1805055 1734303 1735514 1739426 1739450
TreeView+ depends on / blocked
 
Reported: 2019-07-29 09:10 UTC by Pranith Kumar K
Modified: 2020-02-20 07:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1734303 1739426 1805055 (view as bug list)
Environment:
Last Closed: 2019-07-30 05:39:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 23121 None Merged cluster/ec: Fix reopen flags to avoid misbehavior 2019-07-30 05:39:43 UTC

Description Pranith Kumar K 2019-07-29 09:10:28 UTC
Description of problem:
    Problem:
    when a file needs to be re-opened O_APPEND and O_EXCL
    flags are not filtered in EC.
    
    - O_APPEND should be filtered because EC doesn't send O_APPEND below EC for
    open to make sure writes happen on the individual fragments instead of at the
    end of the file.
    
    - O_EXCL should be filtered because shd could have created the file so even
    without O_EXCL open should succeed.
    
    Fix:
    Filter out these two flags in reopen.


Version-Release number of selected component (if applicable):


How reproducible:
Found while reading code.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Amar Tumballi 2019-07-30 05:25:19 UTC
https://review.gluster.org/#/c/glusterfs/+/23121/ posted.

Comment 2 Worker Ant 2019-07-30 05:39:45 UTC
REVIEW: https://review.gluster.org/23121 (cluster/ec: Fix reopen flags to avoid misbehavior) merged (#4) on master by Pranith Kumar Karampuri


Note You need to log in before you can comment on or make changes to this bug.