Bug 1805055 - Open fd heal should filter O_APPEND/O_EXCL
Summary: Open fd heal should filter O_APPEND/O_EXCL
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1733935
Blocks: 1734303 1735514 1739426 1739450 1806848
TreeView+ depends on / blocked
 
Reported: 2020-02-20 07:42 UTC by Pranith Kumar K
Modified: 2020-03-02 08:36 UTC (History)
3 users (show)

Fixed In Version: glusterfs-5.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1733935
Environment:
Last Closed: 2020-02-25 10:17:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 24151 0 None Merged cluster/ec: Fix reopen flags to avoid misbehavior 2020-02-25 10:17:12 UTC

Description Pranith Kumar K 2020-02-20 07:42:23 UTC
+++ This bug was initially created as a clone of Bug #1733935 +++

Description of problem:
    Problem:
    when a file needs to be re-opened O_APPEND and O_EXCL
    flags are not filtered in EC.
    
    - O_APPEND should be filtered because EC doesn't send O_APPEND below EC for
    open to make sure writes happen on the individual fragments instead of at the
    end of the file.
    
    - O_EXCL should be filtered because shd could have created the file so even
    without O_EXCL open should succeed.
    
    Fix:
    Filter out these two flags in reopen.


Version-Release number of selected component (if applicable):


How reproducible:
Found while reading code.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Amar Tumballi on 2019-07-30 05:25:19 UTC ---

https://review.gluster.org/#/c/glusterfs/+/23121/ posted.

--- Additional comment from Worker Ant on 2019-07-30 05:39:45 UTC ---

REVIEW: https://review.gluster.org/23121 (cluster/ec: Fix reopen flags to avoid misbehavior) merged (#4) on master by Pranith Kumar Karampuri

Comment 1 Worker Ant 2020-02-20 08:33:50 UTC
REVIEW: https://review.gluster.org/24151 (cluster/ec: Fix reopen flags to avoid misbehavior) posted (#1) for review on release-5 by Pranith Kumar Karampuri

Comment 2 Worker Ant 2020-02-25 10:17:14 UTC
REVIEW: https://review.gluster.org/24151 (cluster/ec: Fix reopen flags to avoid misbehavior) merged (#3) on release-5 by Pranith Kumar Karampuri

Comment 3 hari gowtham 2020-03-02 08:36:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.12, please open a new bug report.

glusterfs-5.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/gluster-users/2020-March/037797.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.