Bug 1739450 - Open fd heal should filter O_APPEND/O_EXCL
Summary: Open fd heal should filter O_APPEND/O_EXCL
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1733935 1739426 1805055
Blocks: 1734303 1735514
TreeView+ depends on / blocked
 
Reported: 2019-08-09 10:48 UTC by Pranith Kumar K
Modified: 2020-02-20 07:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1739426
Environment:
Last Closed: 2019-11-05 07:10:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 23202 None Merged cluster/ec: Fix reopen flags to avoid misbehavior 2019-11-05 07:10:53 UTC

Description Pranith Kumar K 2019-08-09 10:48:31 UTC
+++ This bug was initially created as a clone of Bug #1739426 +++

+++ This bug was initially created as a clone of Bug #1733935 +++

Description of problem:
    Problem:
    when a file needs to be re-opened O_APPEND and O_EXCL
    flags are not filtered in EC.
    
    - O_APPEND should be filtered because EC doesn't send O_APPEND below EC for
    open to make sure writes happen on the individual fragments instead of at the
    end of the file.
    
    - O_EXCL should be filtered because shd could have created the file so even
    without O_EXCL open should succeed.
    
    Fix:
    Filter out these two flags in reopen.


Version-Release number of selected component (if applicable):


How reproducible:
Found while reading code.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Amar Tumballi on 2019-07-30 05:25:19 UTC ---

https://review.gluster.org/#/c/glusterfs/+/23121/ posted.

--- Additional comment from Worker Ant on 2019-07-30 05:39:45 UTC ---

REVIEW: https://review.gluster.org/23121 (cluster/ec: Fix reopen flags to avoid misbehavior) merged (#4) on master by Pranith Kumar Karampuri

--- Additional comment from Worker Ant on 2019-08-09 10:10:36 UTC ---

REVIEW: https://review.gluster.org/23191 (cluster/ec: Fix reopen flags to avoid misbehavior) posted (#1) for review on release-7 by Pranith Kumar Karampuri

Comment 1 Worker Ant 2019-08-09 11:30:37 UTC
REVIEW: https://review.gluster.org/23202 (cluster/ec: Fix reopen flags to avoid misbehavior) posted (#1) for review on release-6 by Pranith Kumar Karampuri

Comment 2 Worker Ant 2019-11-05 07:10:54 UTC
REVIEW: https://review.gluster.org/23202 (cluster/ec: Fix reopen flags to avoid misbehavior) merged (#2) on release-6 by Pranith Kumar Karampuri


Note You need to log in before you can comment on or make changes to this bug.