Bug 173684 - Missing “Requires: xorg-x11-xauth”
Missing “Requires: xorg-x11-xauth”
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 173693 (view as bug list)
Depends On:
Blocks: xorg-modular
  Show dependency treegraph
 
Reported: 2005-11-18 16:53 EST by Dawid Gajownik
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-22 21:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Gajownik 2005-11-18 16:53:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051107 SeaMonkey/1.5a

Description of problem:
Please add:

Requires: xorg-x11-xauth

to the spec file.

Version-Release number of selected component (if applicable):
xorg-x11-xinit-0.99.3-5

How reproducible:
Always

Steps to Reproduce:
1. Install minimal system
2. yum install xorg-x11-xinit
3. startx
  

Actual Results:  [y4kk0@X ~]$ LANG=C startx
/usr/bin/startx: line 132: xauth: command not found
/usr/bin/startx: line 142: /usr/bin/xauth: No such file or directory
/usr/bin/startx: line 144: /usr/bin/xauth: No such file or directory
/usr/bin/startx: line 142: /usr/bin/xauth: No such file or directory
/usr/bin/startx: line 144: /usr/bin/xauth: No such file or directory


This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.

[snip]

Expected Results:  No errors.

Additional info:
Comment 1 Dawid Gajownik 2005-11-19 06:04:21 EST
*** Bug 173693 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2005-11-22 21:26:55 EST
Thanks for the report.  I've verified the problem, and fixed it in the
latest package.  I used "Requires: xauth" instead, which is a virtual
provide, and futureproofs the package should the package containing
the xauth binary ever change.

* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
- Add "Requires: xauth" for startx, to fix bug (#173684)

Note You need to log in before you can comment on or make changes to this bug.