Bug 173856 - Remove /usr/X11R6/bin from default $PATH
Remove /usr/X11R6/bin from default $PATH
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
: Patch
: 177268 178771 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 17:15 EST by Ville Skyttä
Modified: 2015-03-04 20:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 08:09:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Remove /usr/X11R6/bin from default $PATH (955 bytes, patch)
2005-11-21 17:15 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-11-21 17:15:27 EST
Now that /usr/X11R6/bin is gone, I think it's safe to remove it from the   
default $PATH too, patch attached.  I'm not a csh user/hacker, so that part  
could use a review.
Comment 1 Ville Skyttä 2005-11-21 17:15:28 EST
Created attachment 121320 [details]
Remove /usr/X11R6/bin from default $PATH
Comment 2 Bill Nottingham 2005-11-21 17:17:02 EST
This would actually require patching login, ssh, and various other utilities as
well...
Comment 3 Phil Knirsch 2006-01-24 14:56:50 EST
Why? Login doesn't set /usr/X11R6/bin in the default PATH environment variable,
nor should it. Same for ssh.

There shouldn't be any application in /usr/X11R6/bin anymore. Just checked
current devel install and no files there.

And if 3rd party applications require /usr/X11R6/bin to be in the PATH variable
then this needs to be handled by those 3rd party apps imho.

Also we're already changing all paths for all other parts of the modular X
change, so this would just be one of the finishing touches imho.

Read ya, Phil
Comment 4 Phil Knirsch 2006-01-24 14:57:24 EST
*** Bug 177268 has been marked as a duplicate of this bug. ***
Comment 5 Phil Knirsch 2006-01-24 14:57:39 EST
*** Bug 178771 has been marked as a duplicate of this bug. ***
Comment 6 Phil Knirsch 2006-01-31 08:09:10 EST
Fix will be in next Rawhide package as no more files are found under /usr/X11R6
in our current development tree.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.