Bug 173989 - Kernel fails to start or to find root filesystem
Summary: Kernel fails to start or to find root filesystem
Keywords:
Status: CLOSED DUPLICATE of bug 174378
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FCMETA_SATA
TreeView+ depends on / blocked
 
Reported: 2005-11-23 14:32 UTC by a.purkiss
Modified: 2013-07-03 02:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-13 11:32:00 UTC


Attachments (Terms of Use)

Description a.purkiss 2005-11-23 14:32:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux x86_64; en) Opera 8.5

Description of problem:
When booting with the 2.6.14-1.1637_FC4 kernel on a machine with an MSI K8N SLI 
Platimum motherboard with two sata disks (a Maxtor 6L250S0 and a Maxtor 7Y250M0) 
the kernel fails to start with the following error message

mkrootdev: label /1 not found
mount: error 19 mounting ext3
ERR0 opening /dev/console!!!! :2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed :22
Kernel panic -not syncing: Attempted to kill init!

Under kernel-2.6.13-1.1532_FC4, the system boots fine with the same setup.
The motherboard is nvidia based and uses the sata_nv module under the old 
kernel.

This kernel has been reported to fix bug 171219, but I am unable to run it. 
Attempts to install the kernel from source have also led to the same problem.


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. Start machine using the kernel
2.
3.
  

Actual Results:  See above

Expected Results:  Kernel should have found sata disk and mounted / file system

Additional info:

giving the kernel root=/dev/sda3 instead of root=LABEL=/ does not solve the 
problem, neither does booting with the single processor kernel. Processor is an 
AMB ATHLON 64 X2 dual core.

Comment 1 Dave Jones 2005-12-13 03:00:18 UTC
*** Bug 174175 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2005-12-13 03:02:34 UTC
Try the kernel at http://people.redhat.com/davej/kernels/Fedora/FC4
which has some SATA fixes which might fix your problem.


Comment 3 a.purkiss 2005-12-13 11:32:00 UTC

*** This bug has been marked as a duplicate of 174378 ***


Note You need to log in before you can comment on or make changes to this bug.