Bug 174175 - Kernel fails to start or to find root filesystem
Kernel fails to start or to find root filesystem
Status: CLOSED DUPLICATE of bug 174378
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 08:11 EST by a.purkiss
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-12 21:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description a.purkiss 2005-11-25 08:11:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux x86_64; en) Opera 8.5

Description of problem:
When booting with the 2.6.14-1.1637_FC4 kernel on a machine with an MSI K8N SLI 
Platimum motherboard with two sata disks (a Maxtor 6L250S0 and a Maxtor 7Y250M0) 
the kernel fails to start with the following error message

mkrootdev: label /1 not found
mount: error 19 mounting ext3
ERR0 opening /dev/console!!!! :2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed :22
Kernel panic -not syncing: Attempted to kill init!

Under kernel-2.6.13-1.1532_FC4, the system boots fine with the same setup.
The motherboard is nvidia based and uses the sata_nv module under the old 
kernel.

This kernel has been reported to fix bug 171219, but I am unable to run it. 
Attempts to install the kernel from source have also led to the same problem.


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. Start machine using the kernel
2.
3.
  

Actual Results:  See above

Expected Results:  Kernel should have found sata disk and mounted / file system

Additional info:

giving the kernel root=/dev/sda3 instead of root=LABEL=/ does not solve the 
problem, neither does booting with the single processor kernel. Processor is an 
AMB ATHLON 64 X2 dual core.
Comment 1 Dave Jones 2005-12-12 21:59:59 EST

*** This bug has been marked as a duplicate of 173989 ***
Comment 2 a.purkiss 2005-12-13 06:33:35 EST

*** This bug has been marked as a duplicate of 174378 ***

Note You need to log in before you can comment on or make changes to this bug.