Bug 174378 - Kernel fails to start or to find root filesystem
Kernel fails to start or to find root filesystem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 173989 174175 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 12:15 EST by a.purkiss
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 06:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description a.purkiss 2005-11-28 12:15:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux x86_64; en) Opera 8.5

Description of problem:
When booting with the 2.6.14-1.1637_FC4 kernel on a machine with an MSI K8N SLI 
Platimum motherboard with two sata disks (a Maxtor 6L250S0 and a Maxtor 7Y250M0) 
the kernel fails to start with the following error message

mkrootdev: label /1 not found
mount: error 19 mounting ext3
ERR0 opening /dev/console!!!! :2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed :22
Kernel panic -not syncing: Attempted to kill init!

Under kernel-2.6.13-1.1532_FC4, the system boots fine with the same setup.
The motherboard is nvidia based and uses the sata_nv module under the old 
kernel.

This kernel has been reported to fix bug 171219, but I am unable to run it. 
Attempts to install the kernel from source have also led to the same problem.


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. Start machine using the kernel
2.
3.
  

Actual Results:  See above

Expected Results:  Kernel should have found sata disk and mounted / file system

Additional info:

giving the kernel root=/dev/sda3 instead of root=LABEL=/ does not solve the 
problem, neither does booting with the single processor kernel. Processor is an 
AMB ATHLON 64 X2 dual core.
Comment 1 Dave Jones 2005-11-28 15:18:48 EST
what does your /etc/fstab look like ?
Comment 2 a.purkiss 2005-11-28 15:29:17 EST
/etc/fstab is below, this works fine for booting the kernel-2.6.13-1.1532_FC4.

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/1                /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/sdb2               /exchange               vfat    defaults        0 0
/dev/md0                /home                   ext3    defaults        1 2
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0

LABEL=SWAP-sda5         swap                    swap    defaults        0 0

/dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,
managed 0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,exec,noauto,
managed 0 0

The /boot/grub/grub.conf entries for the working and failing kernel are as 
follows
title Fedora Core (2.6.14-1.1637_FC4smp)
        root (hd0,1)
        kernel /vmlinuz-2.6.14-1.1637_FC4smp ro root=/dev/sda3 rhgb quiet
        initrd /initrd-2.6.14-1.1637_FC4smp.img
title Fedora Core (2.6.13-1.1532_FC4smp)
        root (hd0,1)
        kernel /vmlinuz-2.6.13-1.1532_FC4smp ro root=LABEL=/1 rhgb quiet
        initrd /initrd-2.6.13-1.1532_FC4smp.img

Swapping root=LABEL=/1 for root=/dev/sda3 gives the same result.

fdisk on /dev/sda is as follows

The number of cylinders for this disk is set to 30515.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/sda: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         623     5004216    7  HPFS/NTFS
/dev/sda2             624         654      249007+  83  Linux
/dev/sda3             655        2479    14659312+  83  Linux
/dev/sda4            2480       30515   225199170    5  Extended
/dev/sda5            2480        2723     1959898+  82  Linux swap / Solaris
/dev/sda6            2724       30515   223239208+  fd  Linux raid autodetect


e2label has the following names:
[root@ottawa ~]# e2label /dev/sda2
/boot1
[root@ottawa ~]# e2label /dev/sda3
/1

Any more info needed?
Comment 3 Dave Jones 2005-11-28 16:04:56 EST
ok, labels look fine.  Can you check your /etc/modprobe.conf to see if that has
an entry for your disk controller ?
I'm wondering if something is missing from your initrd.
Comment 4 a.purkiss 2005-11-29 06:43:00 EST
Here is my current (from working kernel) /etc/modprobe.conf

#alias eth0 forcedeth
# Add nforce ethernet and sound drivers
# eth0
alias eth0 nvnet
alias forcedeth off
# sound
alias sound-slot-0 nvsound
#alias snd-intel8x0 off
#alias i810_audio off
install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/
nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; 
/sbin/modprobe -r --ignore-remove nvsound

#alias scsi_hostadapter sata_nv
#alias snd-card-0 snd-ca0106
#options snd-card-0 index=0
#options snd-ca0106 index=0
#remove snd-ca0106 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/
modprobe -r --ignore-remove snd-ca0106
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394


Note that I'm using the nvidia ethernet driver (and the sound card driver is in 
the process of being set up). I've made no other changes
Comment 5 a.purkiss 2005-11-29 08:10:20 EST
And in addition to the above, running the following command to preload the 
sata_nv and libata modules in the ramdisk doesn't not seem to solve the problem.

mkinitrd --preload sata_nv --with=sata_nv --preload=libata /boot/initrd-2.6.14-
1.1637_FC4smp 2.6.14-1.1637_FC4smp.img
Comment 6 a.purkiss 2005-11-29 11:57:30 EST
Have just installed kernel 2.6.14-1.1644_FC4smp and this still has the same 
problem.
Comment 7 Dave Jones 2005-11-29 18:22:28 EST
note that you have the scsi_hostadapter line commented out.
This will make this module not end up in the initrd.
rpm -e the 1644 kernel, uncomment this, and then reinstall the 1644 kernel, and
that *should* fix it.
Comment 8 a.purkiss 2005-11-30 06:39:14 EST
(In reply to comment #7)
> note that you have the scsi_hostadapter line commented out.
> This will make this module not end up in the initrd.
> rpm -e the 1644 kernel, uncomment this, and then reinstall the 1644 kernel, 
and
> that *should* fix it.
> 

Ugghhh, can't believe that I didn't notice that I had that commented out, must 
have commented one line too many when playing with the nvsound module.



Comment 9 a.purkiss 2005-12-13 06:32:26 EST
*** Bug 173989 has been marked as a duplicate of this bug. ***
Comment 10 a.purkiss 2005-12-13 06:33:39 EST
*** Bug 174175 has been marked as a duplicate of this bug. ***
Comment 11 a.purkiss 2005-12-13 06:39:00 EST
Please not that the duplicates appear to have been a bugzilla problem. I only 
submitted the problem once.

Note You need to log in before you can comment on or make changes to this bug.