Bug 174033 - UrlInstallMethod instance has no attribute 'switchMedia'
UrlInstallMethod instance has no attribute 'switchMedia'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 174180 174330 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-23 18:01 EST by Andrew Parker
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 04:25:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file (402.81 KB, text/plain)
2005-11-23 18:02 EST, Andrew Parker
no flags Details
Same problem, ftp install (495.04 KB, text/plain)
2005-12-08 13:19 EST, Frédéric St-Louis
no flags Details

  None (edit)
Description Andrew Parker 2005-11-23 18:01:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
I get an exception during an HTTP install: 

    AttributeError: UrlInstallMethod instance has no attribute 'switchMedia'




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  I copied the contents of each CD into a single directory.  i.e., there is only one Fedora/RPMS directory and it has all (1481) the rpms from each CD in it.  Add directory to Apache.
2.  Install via HTTP
3.  Deselect all package groups (not necessary to reproduce the fault)
4.  Format file systems
5.  Starting install process, then immediately get a "Exception ocurred" dialog box.
  

Actual Results:  Stack dump appears on the screen, along with a dialog box to save it.  Am unable to save to floppy (its USB, and not detected) or to a remote host (what transport is it using?  I have no idea what services to enable/configure.)

Additional info:
Comment 1 Andrew Parker 2005-11-23 18:02:56 EST
Created attachment 121419 [details]
Anaconda dump file
Comment 2 Jeremy Katz 2005-11-24 22:04:26 EST
Hmm, the repodata isn't the same right now between the ftp/http/nfs version of
the tree and the CDs.  Re-running createrepo or syncing down the repodata dir
from the ftp site should workaround.

Need to fix better for test2, though.
Comment 3 Andrew Parker 2005-11-25 17:51:13 EST
I can confirm that a createrepo does in fact allow the install to continue.

More specifically, for those that may be having the same problem, here's what I did:

cd to http directory (the one with the repodata and Fedora directories in it)
mv repodata repodata.deathrow
cp repodata.deathrow/comps.xml repodata
createrepo -g repodata/comps.xml .
Comment 4 Jeremy Katz 2005-11-27 20:25:54 EST
*** Bug 174330 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2005-11-28 11:50:14 EST
*** Bug 174180 has been marked as a duplicate of this bug. ***
Comment 6 Ian Pilcher 2005-11-28 14:08:04 EST
Re comment #3, are you missing a step where you create a new repodata directory?

Also, it might be necessary to change the SELinux context of any new files and
directories that get created to system_u:object_r:httpd_sys_content_t.
Comment 7 Ian Pilcher 2005-11-28 14:10:33 EST
And where did createrepo come from?
Comment 8 Andrew Parker 2005-11-28 19:22:37 EST
(In reply to comment #6)
> Re comment #3, are you missing a step where you create a new repodata directory?

shocker, yes.

> Also, it might be necessary to change the SELinux context of any new files and
> directories that get created to system_u:object_r:httpd_sys_content_t.

not in my case, but then i always disable selinux

(In reply to comment #7)

> And where did createrepo come from?

this was from an existing fc4 install:

$ rpm -qf `which createrepo`
createrepo-0.4.2-2
Comment 9 Frédéric St-Louis 2005-12-08 13:19:58 EST
Created attachment 122037 [details]
Same problem, ftp install

The same problem occurs doing an ftp install.

Note You need to log in before you can comment on or make changes to this bug.