Bug 174038 - Installer crashes shortly after loading ohci1394
Installer crashes shortly after loading ohci1394
Status: CLOSED DUPLICATE of bug 174342
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 174088 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 18:52 EST by Ryan Ordway
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 22:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Ordway 2005-11-23 18:52:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When booting the FC5test1 installation CD (both the boot.iso and disc1.iso), the installation starts as expected, but dies shortly after loading the ohci1394 driver. An 'install exited abnormally -- received signal 11' error appears on the blue driver loading screen, and it ends the installation.
When attempting to use noprobe or nofirewire, the installation does the same thing but without attempting to load ohci1394.

Console text is:

...
running install...
running /sbin/loader
install exited abnormally -- received signal 11
sending termination signals...done 
...

I have tried both the boot.iso and disc1.iso images, and both die with this same behavior.

This is on a Dell Latitude C840.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Power on computer
2. Insert FC5test1 boot media
3. Attempt to install FC5test1
4. Watch it die
  

Additional info:
Comment 1 Marius Andreiana 2005-11-24 15:18:45 EST
*** Bug 174088 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2005-11-24 22:13:14 EST
What's the last thing on tty3 when it fails?  
Comment 3 Bernd Bartmann 2005-11-25 04:23:47 EST
These are the last messages on tty3:

inserted /tmp/ieee1394.ko
inserted /tmp/ohci1394.ko
load module set done
probing for firewire scsi devices
modules to insert pcmcia_core yenta_socket pcmcia
load module set done

On tty4 I get:

<6>ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[11] MMIO=[f8fff000-f8fff7ff]
Max Packet=[2048]
<7>ieee1394: Host added: ID:BUS[0-00:1023]  GUID[334fc000169b3010]
<6>cs: IO port probe 0x100-0x3af: excluding 0x170-0x177 0x280-0x287 0x370-0x37f
<6>cs: IO port probe 0x100-0x3af: excluding 0x170-0x177 0x280-0x287 0x370-0x37f
Comment 4 Jeremy Katz 2005-11-25 11:55:42 EST
Does booting with 'linux nopcmcia' help?
Comment 5 Bernd Bartmann 2005-11-26 06:50:53 EST
I'm afraid "linux nopcmcia" does not help. The installer still crashes with
signal 11.

On tty3 the last messages are now:
inserted /tmp/ieee1394.ko
inserted /tmp/ohci1394.ko
load module set done
probing for firewire scsi devices

On tty4 I get:
<6>ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[11] MMIO=[f8fff000-f8fff7ff]
Max Packet=[2048]
<7>ieee1394: Host added: ID:BUS[0-00:1023]  GUID[334fc000169b3010]

So the pcmcia messages are gone now but the installer still crashes.

Comment 6 Jeremy Katz 2005-11-26 11:14:21 EST
Can you add 'debug' to your boot command line so that all the messages to debug
level from anaconda end up on tty3.  Then maybe I'll be able to better tell
where it's hanging :/
Comment 7 Bernd Bartmann 2005-11-26 11:25:48 EST
I don't any additional output generated by added "debug" I tried:
1. linux debug
2. linux nopcmcia debug
All the messages on tty3 and tty4 look exactly like listed ealier.

BTW: Is there any way to capture the output to tty* somewhere (file, serial
console)?
Comment 8 Chris Lumens 2005-11-29 10:02:29 EST
Try loglevel=debug instead of just "debug" to get the messages on tty3.  All the
output is captured to /tmp/anaconda.log during installation.  You can switch
over to tty2 and examine that file.
Comment 9 Bernd Bartmann 2005-11-29 13:28:28 EST
Ok, loglevel=debug gives some more output:

INFO: modules to insert pcmcia_core yenta_socket pcmcia
DEBUG: module(s) pcmcia_core yenta_socket pcmcia not found
INFO: load module set done
DEBUG: probing buses

I get nothing on tty2 and there is no way to access/save /tmp/anaconda.log.

After playing around a little bit I noticed that I that installer won't die at
this point if I remove my Fritz!CARD PCMCIA. Strange enough the installer does
not die with my no-name WLAN inserted. 

 
Comment 10 Ryan Ordway 2005-11-29 15:25:56 EST
I've not had a chance to try loglevel=debug yet. I'm at home, so my laptop
needs to be running.

My laptop has no PCMCIA cards, just a Dell Mini-PCI wireless card.
Comment 11 Alexandre Oliva 2005-11-30 11:45:55 EST
This sounds a lot like bug 174342
Comment 12 Jeremy Katz 2005-11-30 22:38:57 EST

*** This bug has been marked as a duplicate of 174342 ***

Note You need to log in before you can comment on or make changes to this bug.