Bug 174342 - Early installer crash if PCMCIA card inserted
Early installer crash if PCMCIA card inserted
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 174038 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-28 05:41 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: fc5t2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 10:50:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-11-28 05:41:30 EST
Note: this may be related to bug 174341 (see also that bug for hardware info).

The FC5test1 installer crashes very early if I have my Compaq WL110 PCMCIA WLAN
card inserted.  The last message shown is "Loading ohci1394 driver...", then
"install exited abnormally -- received signal 11".

Last three lines in VT3:
probing for firewire scsi devices
modules to insert pcmcia_core yenta_socket pcmcia
load module set done

Last three lines in VT4:
<7> ieee1394: Host added: ID:BUS[0-00:1023] GUID[...]
<6> cs: IO port probe 0x100-0x3af: clean
<6> cs: IO port probe 0x100-0x3af: clean

--- offtopic:
I had hard time getting this card to work in FC5test1, whereas it worked easily
with FC4.  For example, both hostap_cs and orinoco_cs were loaded for the card,
and I could never get it to work before doing all of the config manually using
orinoco_cs as it was in FC4 and blacklisting hostap_cs in /etc/modprobe.conf. 
Is this worth reporting separately against some component?
Comment 1 Alexandre Oliva 2005-11-30 11:40:12 EST
Identical crash with a wired pcmcia network card, an old 3COM 10/100 card
controlled by 3c574_cs, so this is not related with wireless.
Comment 2 Jeremy Katz 2005-11-30 22:39:18 EST
*** Bug 174038 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Ordway 2005-12-01 13:06:01 EST
Would my Mini-PCI wireless card really fall into the PCMCIA category? My Dell
laptop is exhibiting this same behavior with no PCMCIA cards inserted, but the
internal Mini-PCI wireless card is activated. It worked just fine with FC4, but
the FC5t1 installer dies exactly as described in Bug 174038. 
Comment 4 Ryan Ordway 2005-12-01 13:13:53 EST
Sure enough, disabling the Mini-PCI wireless card in the BIOS kept the installer
from crashing. So far I'm up to package selection with no problems, other than
the lack of wireless support.
Comment 5 Jack Neely 2005-12-20 21:56:10 EST
Also confirmed with an Orinoco mini-pci card.  This card acts as a pcmcia card.
Comment 6 Chris Lumens 2006-01-17 13:49:58 EST
Please try again with test 2, as some kudzu and loader fixes have gone in
relating to PCMCIA segmentation faults in anaconda.
Comment 7 Bernd Bartmann 2006-01-17 15:11:59 EST
Fixed for me on FC5T2.

Note You need to log in before you can comment on or make changes to this bug.