Bug 174113 - screen drawing problems in 24/32bit mode
screen drawing problems in 24/32bit mode
Status: CLOSED DUPLICATE of bug 173357
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 13:11 EST by David Bentley
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 07:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current xorg.conf (2.52 KB, text/plain)
2005-11-24 13:19 EST, David Bentley
no flags Details

  None (edit)
Description David Bentley 2005-11-24 13:11:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.10) Gecko/20050811 Fedora/1.7.10-1.1.1.legacy

Description of problem:
Incorrect colours and multiply drawn icons when in millions of colours mode.

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-1.0.1-1

How reproducible:
Always

Steps to Reproduce:
accept instalation default bit depth.

Actual Results:  As description

Expected Results:  properly drawn screen

Additional info:

My video card is an ATI Radeon 6800 Pro 

Why is it using the vesa driver.

I will attach my xorg.conf file later.
Comment 1 David Bentley 2005-11-24 13:19:43 EST
Created attachment 121459 [details]
current xorg.conf

conf file shows 16 bit only (as the result of a second install after all the 
.iso immages had been downloaded)
Comment 2 David Bentley 2005-11-25 08:16:25 EST
I suspect that the vesa driver is a leftover from the install process (failsafe)
and at firstboot when you select the resolution and bit depth the vesa driver 
gets carried over.

All the video problems dissapearfor me on editing xorg.conf to use the radeon
driver.

However there is still a problem using the vesa driver with this hardware.

Should anything be filed against anaconda or firstboot regarding the wrong
driver selection.
Comment 3 n0dalus 2005-11-26 05:03:31 EST
I think this is a dupe of bug 174101.
Comment 4 David Bentley 2006-01-22 10:18:33 EST
Altered to FC5T2 as this behaviour is still seen on a fresh install of FC5T2.

The significant differance is that the vesa driver now seems to support 24/32
bit colour OK on this hardware.
Comment 5 Mike A. Harris 2006-01-31 13:04:25 EST
2 problems here.

1) that vesa driver is getting used instead of radeon
2) bug in fb code which causes display corruption.

There is a bug tracking each of these issues already, although I don't have the
bug ID's handy.  The first problem should be fixed in the next driver update,
which should happen sometime this week.  The second problem should happen
in a future server package update, sometime in the next week or so.

I'll update the report once both issues are released to rawhide.

Thanks for the report.
Comment 6 Mike A. Harris 2006-02-03 07:43:45 EST
Ok, both #1 and #2 from comment #5 are resolved in the latest rpms in
rawhide.  They'll be in rawhide on Saturday around noon EST roughly.

*** This bug has been marked as a duplicate of 173357 ***

Note You need to log in before you can comment on or make changes to this bug.