Bug 174101 - Anaconda loads vesa video driver vice radeon
Anaconda loads vesa video driver vice radeon
Status: CLOSED DUPLICATE of bug 173357
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 175804 176057 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-24 11:01 EST by Clyde E. Kunkel
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 02:49:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of desktop using vesa driver (69.66 KB, image/jpeg)
2005-11-26 05:09 EST, n0dalus
no flags Details

  None (edit)
Description Clyde E. Kunkel 2005-11-24 11:01:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Reboot after firstboot.  Double icons on screen, icons on gnome taskbar squashed together, colors off.  Moving top taskbar to right side cleared up taskbar probs, but moving it back brought them back.

Found vesa driver being loaded in xorg.conf.  Changed to radeon, restarted X and life was good again.  This is the first time this has happened and I have isntalled all test releases from scratch subsequent to FC1.

Version-Release number of selected component (if applicable):
FC5T1

How reproducible:
Always

Steps to Reproduce:
1.Install FC5T1
2.reboot after firstboot
3.
  

Actual Results:  Garbled display as described above.

Expected Results:  Normal, clean Fedora screen.

Additional info:
Comment 1 Jeremy Katz 2005-11-24 22:18:17 EST
This is due to the mapping in hwdata not containing the PCI id in question. 
We're moving towards having this info in each individual driver package, though,
so assigning to xorg-x11-drv-ati
Comment 2 n0dalus 2005-11-26 05:09:42 EST
Created attachment 121500 [details]
Screenshot of desktop using vesa driver
Comment 3 Levin Fritz 2005-11-27 16:40:03 EST
Same here, with an "ATI Technologies Inc RV280 [Radeon 9200] (rev 01)" graphics
adapter. The PCI id is 1002:5961, if I interpreted lspci's output correctly.
Comment 4 David Bentley 2005-12-08 04:53:17 EST
If you switch to 16bit color mode the vesa driver works OK.
The screen drawing problem with my card (Radeon 9800 Pro)is 
also cured by editing the xorg.conf and replacing the vesa
driver with the radeon driver. 

There is still this screen drawing problem with the vesa driver
on my hardware in 24/32 bit color mode. See bug 174113
Comment 5 Jens Petersen 2005-12-18 03:49:40 EST
*** Bug 175804 has been marked as a duplicate of this bug. ***
Comment 6 Clyde E. Kunkel 2005-12-18 09:38:20 EST
Clean install from rawhide on 16 Dec showed that the vesa driver is still being
loaded, and depth is still at 24.
Comment 7 Clyde E. Kunkel 2006-01-05 20:30:20 EST
Clean install from rawhide on 5 Jan 2006 showed that vesa driver vice radeon is
still being installed.  Depth is 24, and screen is good, but reduced in size. 
Changing driver to radeon vice vesa in xorg.conf fixed.  

This system has two radeon cards:  radeon 9200 on AGP and radeon 9200SE on PCI.
 BIOS is set for AGP, but during install anaconda listed the graphics card as
the PCI card even tho the monitor is attached to the AGP card.  Would have
expected it to list the AGP card.  xorg.conf says the board is the 9200SE card,
but X works fine after changing the driver.
Comment 8 Mike Chambers 2006-01-11 03:24:51 EST
*** Bug 176057 has been marked as a duplicate of this bug. ***
Comment 9 Mike Chambers 2006-01-11 03:25:27 EST
*** Bug 176057 has been marked as a duplicate of this bug. ***
Comment 10 Jens Petersen 2006-01-11 03:31:10 EST
I didn't see this anymore with a fresh install of rawhide-20060103.
Comment 11 Clyde E. Kunkel 2006-01-11 13:30:06 EST
Will take a look with a clean install of FC5T2 when the CDs are available.
Comment 12 n0dalus 2006-01-28 20:06:45 EST
I still get this on FC5T2.

The colour and icon problems are fixed but the resolution won't go above
1280x1024 and attempting to switch to any other resolution results in display
problems (X needs to be restarted and virtual terminals stop working).

Setting it to use radeon instead of vesa fixes these problems.

(Using Ati Radeon 9600XT)
Comment 13 Mike A. Harris 2006-02-03 02:49:11 EST
There are 2 problems occuring here:

1) The vesa driver being assigned instead of radeon (bug #173357)

2) A bug in the fb layer of the X server which causes display glitches in
   24bpp.

Problem #1 should be resolved with xorg-x11-drv-ati-6.5.7.3-2 which has
just been built in rawhide, and should be available publically on Saturday,
if it isn't there on Friday.

Bug was filed as "vesa driver chosen instead of rawhide" which is now fixed,
so I'm closing this now.  Problem #2 is already being tracked in another
bug report I don't have handy, however it should also be fixed tonight, or
within a few days.  If problem #2 still occurs with the vesa or any other
driver on Monday, feel free to file a separate bug report if you can't
find the existing one tracking it, and I'll close them as dupes when I
locate them all.  I think there are a number of dupes reported on
different hardware (since it's a generic server bug), so another one wont
hurt much. ;)

Thanks guys!

*** This bug has been marked as a duplicate of 173357 ***

Note You need to log in before you can comment on or make changes to this bug.