Bug 173357 (videoaliases) - Driver packages should include aliases
Summary: Driver packages should include aliases
Status: CLOSED RAWHIDE
Alias: videoaliases
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 174101 174113 179527 179902 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-11-16 16:19 UTC by Bill Nottingham
Modified: 2014-03-17 02:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 07:35:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
master alias list (33.29 KB, text/plain)
2005-11-16 16:19 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2005-11-16 16:19:18 UTC
As mentioned on xgl-devel, please place the appropriate aliases from the
attached in the various driver packages, as
/usr/share/hwdata/videoaliases/<driver>

Comment 1 Bill Nottingham 2005-11-16 16:19:18 UTC
Created attachment 121135 [details]
master alias list

Comment 2 Jeremy Katz 2006-01-18 15:59:02 UTC
Any progress here?

Comment 3 Mike A. Harris 2006-02-03 07:35:49 UTC
The master videoaliases file has been split up into per-driver files now,
named <driver>.xinf

Some drivers do not have any .xinf files, as the master didn't have entries
for them, and presumeably our pcitable/Cards databases didn't have entries
for them before either.  Some of those drivers are mainly ISA drivers
however, so .xinf entries don't make sense anyway.

If there are any accidental omissions or updates needed, we'll do that
as bugs get reported, however we can close this as RAWHIDE now.  It probably
wont hit public servers until Saturday's rawhide push though, as I slightly
missed the 2:00am rawhide compose.

Now that this is present in rawhide, if any new autodetection bugs come in,
please request the person to update to the latest Fedora development
drivers, and have them run "system-config-display --reconfig" to confirm
if their problem still exists.  For installer time problems, people will
need to do text install and update, then manually run s-c-d.

Thanks guys.

Comment 4 Mike A. Harris 2006-02-03 07:43:12 UTC
IMPORTANT NOTE TO USERS:

For those who install Fedora Core 5 test1 or test2 releases, you will find
that if you've done a brand new OS install, that the installer will have
configured your video card to use the "vesa" driver, regardless of what
video card you have.  That was a temporary problem, which has recently
just been resolved (as mentioned in comment #3 above) now in the latest
Fedora Core development packages.

For those who have FC5 test1 or 2 installed already, update with "yum update"
to get the latest packages, then run "system-config-display --reconfig"
manually.  You should now get the proper video driver assigned.

For those who are unable to install because of this issue, please do a text
mode installation, and then follow the instructions above for updating.

This problem should be resolved when FC5test3 is released.



[ I've given this bug a bug alias of "videoaliases" to make it easier to
  close duplicates. ]

Comment 5 Mike A. Harris 2006-02-03 07:49:21 UTC
*** Bug 174101 has been marked as a duplicate of this bug. ***

Comment 6 Mike A. Harris 2006-02-03 12:03:09 UTC
*** Bug 179527 has been marked as a duplicate of this bug. ***

Comment 7 Mike A. Harris 2006-02-03 12:43:53 UTC
*** Bug 174113 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2006-02-03 19:54:32 UTC
*** Bug 179902 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.