Bug 174614 - emacs should require xorg-x11-fonts-ISO8859-1-{75,100}dpi
emacs should require xorg-x11-fonts-ISO8859-1-{75,100}dpi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 174656 (view as bug list)
Depends On: 174416
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 13:29 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 13:47:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-11-30 13:29:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Without helvetica.*iso8859-1 fonts installed, emacs complains on start up and actually displays some content horribly.  Since these font packages are not installed by default, emacs complains by default.  Surely it's not installed by default either, but...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FC5test1
2.Install emacs atop of that
3.Start emacs from a terminal with DISPLAY enabled
4.Install the fonts packages
5.Start emacs again

Actual Results:  Complaint on 3, no complaint on 5

Expected Results:  No complaint.  Perhaps use the 10646 (Unicode, right?) fonts by default?

Additional info:
Comment 1 Jens Petersen 2005-12-01 00:41:39 EST
*** Bug 174656 has been marked as a duplicate of this bug. ***
Comment 2 Jens Petersen 2005-12-01 00:46:09 EST
Just xorg-x11-fonts-ISO8859-1-75dpi is sufficient, or are both fonts required?

[AFAIK emacs isn't good at unicode fonts.]
Comment 3 Jens Petersen 2005-12-01 00:47:51 EST
Does emacs still require xorg-x11-fonts-75dpi?

[Sorry I can't test this right now, since rawhide isn't installing
for me currently.]
Comment 4 Jonathan Kamens 2005-12-01 08:26:04 EST
Yes, it's still requiring xorg-x11-fonts-75dpi.  I don't know whether it 
should be requiring ISO8859-1-75dpi instead of or in addition to the other 
package.  I suspect that just 75dpi is sufficient, i.e., it probably isn't 
necessary to require both the 75dpi and 100dpi packages, but I haven't tested 
that theory.
Comment 5 Jens Petersen 2005-12-14 03:24:45 EST
Ok seems the iso8859-1 encoded fonts were separated out.
Thanks for the report - should be fixed in 21.4-11.
Comment 6 Alexandre Oliva 2005-12-16 12:09:29 EST
Confirmed fixed; only 75dpi fonts are required, I hope that's good enough.
Comment 7 Jens Petersen 2005-12-16 22:00:34 EST
Right, I'm not very sure about 75dpi vs 100dpi these days.
Are 75dpi an anacronism now or does it really make any difference
for apps like Emacs say?  Would it make more sense to install both?

XEmacs is requiring both.
Comment 8 Jens Petersen 2005-12-18 22:04:46 EST
Ok, I tested with 100dpi instead of 75dpi and IMO the default
window with 100dpi is too big, so I think just 75dpi is good enough
and sufficient.  Those who want the higher quality large 100dpi display
can install the 100dpi font and reorder the xfs font path.
Comment 9 Orion Poplawski 2006-01-04 17:03:54 EST
It seems like this has snuck back in:

> emacs
Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*"
to type FontStruct
Warning: Cannot convert string
"-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct

And the characters show up as boxes.

# rpm -qa *font* | sort
bitmap-fonts-0.3-5.1
bitstream-vera-fonts-1.10-5.1
chkfontpath-1.10.0-4.1
fontconfig-2.3.93-2
fontconfig-2.3.93-2
fonts-japanese-0.20050222-11.1
ghostscript-fonts-5.50-13.1
libfontenc-1.0.0-1
libfontenc-1.0.0-1
libXfont-1.0.0-1
libXfontcache-1.0.0-1
mathml-fonts-1.0-20.fc5
msttcorefonts-1.3-4
tetex-fonts-3.0-13
urw-fonts-2.3-6.1
xorg-x11-fonts-base-1.0.0-1
xorg-x11-fonts-ISO8859-1-75dpi-1.0.0-1
xorg-x11-font-utils-1.0.0-1

# xlsfonts | grep courier-medium
# xlsfonts | grep helvetica-medium
#     
Comment 10 Mikko Huhtala 2006-01-07 08:25:45 EST
I can confirm this. I get the 'cannot convert' errors and characters show up as
empty boxes. I have both 75dpi and 100dpi RPMS installed and tried both 'en_US'
and 'en_US.UTF-8' for LANG.
Comment 11 Jens Petersen 2006-01-09 02:37:32 EST
I believe this is because bug 174416 hasn't been fixed yet.
Comment 12 Bill Nottingham 2006-01-31 14:08:26 EST
Why does this need the iso8859-1 fonts,in any case - it's not like we're running
in that locale,in general.
Comment 13 Jens Petersen 2006-01-31 20:45:58 EST
Because that is the font that emacs uses by default irrespective of the locale.

Note You need to log in before you can comment on or make changes to this bug.