Bug 174416 - "fonts.dir" not updated after installing "xorg-x11-fonts-ISO8859-1"
"fonts.dir" not updated after installing "xorg-x11-fonts-ISO8859-1"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: EasyFix, Regression
: 174673 178758 (view as bug list)
Depends On:
Blocks: FC5Blocker 174614 174617
  Show dependency treegraph
 
Reported: 2005-11-28 15:29 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 06:11:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2005-11-28 15:29:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Epiphany/1.8.2

Description of problem:
After installation of the iso 8859 font packages,
they are not available upon reboot of the system.

Version-Release number of selected component (if applicable):
xorg-x11-fonts-ISO8859-1-100dpi/75dpi-0.99.0-8

How reproducible:
Always

Steps to Reproduce:
1. Install iso8859 font RPMs.
2. Reboot system.
  

Actual Results:  Various applications continue to complain about missing
iso8859 fonts.

Expected Results:  The added iso8859 fonts should be available to the
X server.

Additional info:

After executing "mkfontdir" in the respective font
directories, the "fonts.dir" files get updated, and
the iso8859 become actually available to the X server.
Comment 1 Jonathan Kamens 2005-12-01 09:54:13 EST
*** Bug 174673 has been marked as a duplicate of this bug. ***
Comment 2 Joachim Frieben 2006-01-05 03:44:43 EST
A fresh net install from "rawhide" reveals that the issue is still not
fixed in "xorg-x11-fonts-ISO8859-1-100dpi-1.0.0-1" and
"xorg-x11-fonts-ISO8859-1-75dpi-1.0.0-1".
Comment 3 Joachim Frieben 2006-01-13 04:31:40 EST
Still not fixed in "xorg-x11-fonts-ISO8859-1-100dpi-1.0.0-2" and
"xorg-x11-fonts-ISO8859-1-75dpi-1.0.0-2".
Comment 4 Alexandre Oliva 2006-01-13 11:18:00 EST
Still broken in FC5T2 candidate.
Comment 5 Mike A. Harris 2006-01-17 21:51:41 EST
Super-DOH!  How the....

xorg-x11-fonts brown paper bag bug #1 right here.  Yep.

Thanks for reporting!  I had a quick look at this one a while back, but
didn't spot anything obvious, so assumed it might possibly be transient
rawhide font configuration issue, which we've had a few of now.

I investigated it deeper just now though, and discovered that the rpm scripts
for the ISO8859-1 fonts were completely missing.  Ugh.  So much for being
extremely careful and diligent during the creation of the new font packages. ;)

Ah well, she's fixed now in 1.0.0-3 and later, and should be in the rawhide
sync tomorrow.

Thanks again, and apologies for any inconveniences caused to everyone due
to this!
Comment 6 Jens Petersen 2006-01-18 21:30:12 EST
Reopening until package actually gets built.
Comment 7 Jens Petersen 2006-01-23 23:31:32 EST
*** Bug 178758 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.