Bug 174617 - xemacs should require xorg-x11-fonts-ISO8859-1-{75,100}dpi
xemacs should require xorg-x11-fonts-ISO8859-1-{75,100}dpi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On: 174416
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 13:38 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 21.4.17-7.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 06:29:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-11-30 13:38:49 EST
+++ This bug was initially created as a clone of Bug #174614 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118
Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Without helvetica.*iso8859-1 fonts installed, emacs complains on start up and
actually displays some content horribly.  Since these font packages are not
installed by default, emacs complains by default.  Surely it's not installed by
default either, but...

With xemacs, the story is a bit different: it does not complain, but displayed
data still looks ugly, especially where boldface is expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FC5test1
2.Install xemacs atop of that
3.Start xemacs from a terminal with DISPLAY enabled
4.Install the fonts packages
5.Start xemacs again

Actual Results:  Complaint on 3, no complaint on 5

Expected Results:  No complaint.  Perhaps use the 10646 (Unicode, right?) fonts
by default?

Additional info:
Comment 1 Ville Skyttä 2005-11-30 14:51:25 EST
Yep, there are known problems with getting XEmacs to use sane fonts on FC5test1,
see bug 173374.

I have tried to persuade XEmacs to use this font for the edit area (not in the
current xemacs-21.4.17-6.fc5 package, but see xfontsel):

    -adobe-courier-medium-r-*-*-*-120-*-*-*-*-iso10646-*

However, if I specify that, XEmacs comes up with actually using something that
doesn't look like at all like the font in xfontsel.  Same thing if I change
iso10646 to "*".  If I in addition to that change "adobe" to "*", the ugly "ibm"
courier is used :(

I'm pretty sure I've tried with the ISO8859-1 font packages installed, but it
didn't make any difference.  Patching x-faces.el (search for courier in it) to
try the iso10646 (adobe) courier before the iso8859 (ibm) one didn't help either.

One way to quickly test this is to copy /usr/share/xemacs-21.4.17/etc/Emacs.ad
to /usr/lib/X11/app-defaults/Emacs (yes, that's "wrong" and should be
/usr/share/X11/app-defaults/Emacs, but I guess that is the result of bug 173593)
and fiddle with Emacs.default.attributeFont.

Ideas?
Comment 2 Ville Skyttä 2005-11-30 17:40:34 EST
Oh, installing the ISO8859-1 font packages fixes things indeed with both XEmacs
and Emacs!  But those packages forgot to run their mkfontdir and friends :(
Comment 3 Ville Skyttä 2005-12-01 06:29:28 EST
ISO8859-1 deps added in 21.4.17-7.fc5.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.