Bug 175223 - gstreamer 0.10 available
gstreamer 0.10 available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: FutureFeature
: 175224 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 16:08 EST by Luya Tshimbalanga
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2005-12-07 16:08:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129 Fedora/1.5-1 Firefox/1.5

Description of problem:
Gstreamer 0.10 and the plugins are available. Is it possible to make them before Fedora Core 5 Test 2?
Gstreamer website already provides srpms packages on
http://gstreamer.freedesktop.org/pkg/fedora/4/

Version-Release number of selected component (if applicable):
gstreamer-0.8.11.2

How reproducible:
Always

Steps to Reproduce:
1. Update to 0.10 version
2.
3.
  

Additional info:
Comment 1 John (J5) Palmieri 2005-12-07 16:48:18 EST
*** Bug 175224 has been marked as a duplicate of this bug. ***
Comment 2 John (J5) Palmieri 2005-12-07 16:52:50 EST
The problem with getting GStreamer 0.10 in is will we have to still support
Gstreamer 0.8?  If all apps are ported to 0.10 or an app in Core absolutely
requires it then it can go in but for now it is probubly better to get it into
extras.  If it is packaged in extras then it will be easier to move it to core
when the time is right.  As per core policy we can not just add library
packages.  There has to be another app that depends on it.
Comment 3 David Andersson 2005-12-14 15:43:56 EST
Current gstreamer apps in fedora core + extra as I know of:
rhythmbox
totem
istanbul
gnome-media
soundconverter
amarok
Rhythmbox and totem have 0.10 ports.
Istanbul, gnome-media and soundconverter might not have ports but shouldn't be
too hard.
Amarok have got patches but i don't think there will be a stable release any
time soon.
There are probably more packages depending on gstreamer.
Comment 4 W. Michael Petullo 2006-01-04 20:44:22 EST
The gstreamer 0.10 packages may be installed in parallel with the 0.8 packages.
 Because of this, I think we should get the ball rolling in Extras.  the
gst-launch utility will provide much to test as we await desktop applications to
be ported.

Many modules have not yet been ported to the 0.10 framework.  Therefore, we are
not only awaiting applications, but also plugins.

See the following package proposals:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176986
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176987

I have provided very fine grained packages in order to address bug #108463. 
Each module that require an external media library is provided in a separate
package.
Comment 5 John (J5) Palmieri 2006-01-04 21:03:25 EST
Wierd timing.  Warren Togammi, worked on getting this in core today and it is
almost there pending the transition of gstreamer08 packages (gstreamer-0.10 will
now be the gstreamer pakages in core and 0.8 is moving to gstreamer-0.8). 
Should be built tomorrow morning.
Comment 6 W. Michael Petullo 2006-01-04 21:07:49 EST
Well, I guess I go and Ctrl-C my ongoing compile...Thanks, John.  I've been
using the packages on my Fedora Raw Hide box for a few days and they seem to
work well.

Can we convince Warren to address bug #108463 in his packages?
Comment 7 John (J5) Palmieri 2006-01-04 21:16:06 EST
Well, I still own the packages.  I'll look into it.  I don't want to split them
up too much but gnome/kde sub packages do make some sense.
Comment 8 Luya Tshimbalanga 2006-01-06 04:27:47 EST
Should this bug report be closed now that gstreamers version 0.10 is available
on Core?
Comment 9 John (J5) Palmieri 2006-01-06 10:53:38 EST
I'll close it after I get all the apps either ported or ref the correct
gstreamer version.  Thanks
Comment 10 Matthias Clasen 2006-02-15 23:42:18 EST
All apps ported now, right John ?
Comment 11 John (J5) Palmieri 2006-02-16 12:55:58 EST
All core apps are, yes
Comment 12 Matthias Clasen 2006-02-21 13:57:29 EST
Assuming  thats the case.

Note You need to log in before you can comment on or make changes to this bug.