Bug 1754407 - geo-rep: non-root session going fault due improper sub-command
Summary: geo-rep: non-root session going fault due improper sub-command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: RHGS 3.5.0
Assignee: Sunny Kumar
QA Contact: Kshithij Iyer
URL:
Whiteboard:
Depends On: 1753928 1755213
Blocks: 1696809
TreeView+ depends on / blocked
 
Reported: 2019-09-23 07:54 UTC by Sunny Kumar
Modified: 2019-10-30 12:23 UTC (History)
12 users (show)

Fixed In Version: glusterfs-6.0-15
Doc Type: No Doc Update
Doc Text:
Clone Of: 1753928
Environment:
Last Closed: 2019-10-30 12:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3249 0 None None None 2019-10-30 12:23:29 UTC

Description Sunny Kumar 2019-09-23 07:54:21 UTC
+++ This bug was initially created as a clone of Bug #1753928 +++

Description of problem:

Non-root session going faulty due to improper sub-command during worker start.



Version-Release number of selected component (if applicable):

mainline

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:

Session going faulty.

Expected results:

Session should not go faulty.


Additional info:

--- Additional comment from Worker Ant on 2019-09-20 19:59:32 UTC ---

REVIEW: https://review.gluster.org/23465 (geo-rep : fix sub-command during worker connection) posted (#1) for review on master by Sunny Kumar

Comment 2 Sunny Kumar 2019-09-23 07:56:15 UTC
Upstream Patch:

https://review.gluster.org/#/c/glusterfs/+/23465/

Comment 16 errata-xmlrpc 2019-10-30 12:23:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.