Bug 175804 - bad gtk rendering with ATI Radeon Xpress 200 on amd64
Summary: bad gtk rendering with ATI Radeon Xpress 200 on amd64
Status: CLOSED DUPLICATE of bug 174101
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-15 08:46 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-18 08:49:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot.png (149.92 KB, image/png)
2005-12-15 08:46 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2005-12-15 08:46:32 UTC
Description of problem:
Since around fc5test1 (when modular X went into rawhide) I have been
experiencing bad rendering in gnome and gtk apps, particularly of icons
but also of tabs say in firefox and gtk apps.

How reproducible:
every time

Steps to Reproduce:
1. Install rawhide or fc5test1 on HP Desktop dx5150
2. log into gnome
3. move mouse pointer around screen, start firefox, gtk-demo, etc  

Actual results:
3. Broken icons rendering and placement on panel, desktop, dialogs, etc.

Expected results:
3. normal rendering as before around fc5test1.

Additional info:
Vesa driver being used for X.
KDE apps and desktop are unaffected.
During installation no rendering problems seen in anaconda gui.

Comment 1 Jens Petersen 2005-12-15 08:46:32 UTC
Created attachment 122266 [details]
Screenshot.png

Comment 2 Carl Worth 2005-12-15 16:49:54 UTC
I'd be very interested in seeing the results of cairo's test suite, ("make
check"), in the cairo source tree.

I'd be glad to help generate that if I could be provided with access to a
machine that demonstrates these problems.

-Carl


Comment 3 Jens Petersen 2005-12-16 04:53:45 UTC
I tried to rebuild our cairo package yesterday but rawhide still seems
too broken.  Suppose I could reinstall test1 and do it there.

Comment 4 Jens Petersen 2005-12-17 12:31:01 UTC
I ran "make check" in cairo-1.0.2/ on a fc5test1 install and got
"All 59 tests behaved as expected (5 expected failures)".

With current anoncvs I got one segfault for ft-font-create-for-ft-face
but all the other tested passed.

If you want to see the test output, please let me know.

Comment 5 n0dalus 2005-12-17 23:19:13 UTC
This looks like a dupe of bug #174101 / bug #174113.

Is xorg.conf set to use the 'vesa' driver? If it is there is a bug with 24 bit
colour. Either change xorg.conf to use the 'radeon' driver (this is probably the
best way), or drop down to 16 bit colours. I don't think it has anything to do
with cairo.

Comment 6 Jens Petersen 2005-12-18 08:49:33 UTC
Thank you very much - in the back of my mind I suspected it
was something like this. :)

*** This bug has been marked as a duplicate of 174101 ***


Note You need to log in before you can comment on or make changes to this bug.