Bug 175890 - su - got permission denied to /root
su - got permission denied to /root
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
: 176464 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-15 18:27 EST by Tim Taiwanese Liim
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-targeted-2.1.6-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 12:35:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Taiwanese Liim 2005-12-15 18:27:53 EST
Description of problem:
    "su -" has permission denied to /root.

Version-Release number of selected component (if applicable):
   fc5test1, installed from iso image.

How reproducible:
  always.

Steps to Reproduce:
1. su -
  
Actual results:
    [timliim@yam ~]$ su -
    Password:
    su: warning: cannot change directory to /root: Permission denied
    su: warning: cannot change directory to /root: Permission denied
    [root@yam timliim]#

Expected results:
    - no warning msg
    - should be in ~root instead of ~user.

Additional info:
Comment 1 n0dalus 2005-12-16 00:25:18 EST
Dupe of bug #174227

Fix is to run: restorecon -v /root
Comment 2 Tim Waugh 2005-12-23 03:45:46 EST
*** Bug 176464 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2006-01-02 11:43:13 EST
Fixed in latest policy

selinux-policy-targeted-2.1.6-19
Comment 4 Wade Mealing 2006-01-16 05:36:37 EST
Confirmed fixed in selinux-policy-targeted-2.1.10-1

Comment 5 Tim Taiwanese Liim 2006-01-16 12:30:43 EST
Confirmed fixed in selinux-policy-targeted-2.1.6-19.  Will close ticket.

Note You need to log in before you can comment on or make changes to this bug.