Bug 175999 - firstboot: TypeError: __init__() got an unexpected keyword argument 'showPages'
Summary: firstboot: TypeError: __init__() got an unexpected keyword argument 'showPages'
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
: 176768 176931 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-17 03:16 UTC by Clyde E. Kunkel
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1/5/2006
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 01:34:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Clyde E. Kunkel 2005-12-17 03:16:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 494, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 77, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 55, in setupScreen
    self.dateWindow = mainWindow.mainWindow (firstboot = True, showPages = ["datetime", "ntp"])
TypeError: __init__() got an unexpected keyword argument 'showPages'


Version-Release number of selected component (if applicable):
rawhide of 16Dec05

How reproducible:
Didn't try

Steps to Reproduce:
1.Install from rawhide
2.
3.
  

Actual Results:  traceback error as above.
Rest of firstboot ok.

Expected Results:  No error

Additional info:

Comment 1 Chris Lumens 2006-01-04 15:28:06 UTC
*** Bug 176931 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2006-01-04 15:34:38 UTC
*** Bug 176768 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2006-01-04 17:15:17 UTC
Please try with the 20060104 tree or later and see if it now works.

Comment 4 Andy Burns 2006-01-05 09:04:57 UTC
This failed (in same way) on jkeating's initial build of i386 rescue CD from
2006-01-04, not sure if this was build using code from before that date though,
will watch for updates ...



Comment 5 Clyde E. Kunkel 2006-01-06 01:34:05 UTC
This now works as of todays clean install of (1.5.2006) rawhide.


Note You need to log in before you can comment on or make changes to this bug.