Bug 176794 - Standard configuration files format
Standard configuration files format
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
: 176791 176792 176793 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 15:36 EST by Pedro Bezunartea
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 15:35:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Bezunartea 2006-01-02 15:36:30 EST
The idea is to use xml/dtd/schemas for all the configuration files in a standard
and if possible, human-readable format. 

Most of the applications and services have very similar configuration needs but
very rarely share a common format. I have searched for information on this
subject but found nothing relevant. The objective would be to have an organized
configuration directory (/etc ?) where the files have a standard and
dtd-compliant format.

The most important benefits would be specially for system administrators that
need to learn as many file formats as services needed... why are the
configuration files for the different MTA applications so different? The same
applies to web, ftp, database, etc... servers.

This could also make the automatization much easier. There are plenty of XML
parsers and checkers. And the checks can be very much customized using
DTD/Schemas. It'd be much easier for applications like webmin.

Thanks for your attention,

Pedro Bezunartea López.
Comment 1 Nalin Dahyabhai 2006-01-02 18:10:54 EST
*** Bug 176791 has been marked as a duplicate of this bug. ***
Comment 2 Nalin Dahyabhai 2006-01-02 18:11:24 EST
*** Bug 176793 has been marked as a duplicate of this bug. ***
Comment 3 Nalin Dahyabhai 2006-01-02 18:11:37 EST
*** Bug 176792 has been marked as a duplicate of this bug. ***
Comment 4 Pedro Bezunartea 2006-01-02 18:20:41 EST
(In reply to comment #1)
> *** Bug 176791 has been marked as a duplicate of this bug. ***

Have I sent this bug 4 times?
Comment 6 Jon Stanley 2008-05-12 15:35:12 EDT
I really don't think that this is possible - most configuration files come from
upstream projects that are completely out of the control of Fedora.  There are
automation tools such as puppet, and the up and coming configuration management
API's such as augeas (http://augeas.net) that may ease your burden.

For now, I'll close this CANTFIX since it's really completely beyond our control.
Comment 7 Pedro Bezunartea 2008-05-12 17:59:33 EDT
I wanted to file a feature request. I guess I should contact the LSB people
about this. I think it's an idea to consider for the future.

Note You need to log in before you can comment on or make changes to this bug.