Bug 176833 - Upgrade to subversion-1.3.0
Upgrade to subversion-1.3.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
http://subversion.tigris.org/svn_1.3_...
: FutureFeature
: 176880 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 10:18 EST by Kenneth Porter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 06:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Porter 2006-01-03 10:18:22 EST
------------ Forwarded Message ------------
Date: Monday, January 02, 2006 7:06 AM +0100
From: David Anderson <david.anderson@calixo.net>
To: dev@subversion.tigris.org, users@subversion.tigris.org,
announce@subversion.tigris.org
Subject: Subversion 1.3.0 released.

I'm happy to announce Subversion 1.3.0, available from:

  http://subversion.tigris.org/downloads/subversion-1.3.0.tar.gz
  http://subversion.tigris.org/downloads/subversion-1.3.0.tar.bz2
  http://subversion.tigris.org/downloads/subversion-1.3.0.zip

The MD5 checksums are:

  a9e69910f648028a159f3886b254261b  subversion-1.3.0.tar.bz2
  0d91a7fe152d0373044c47c54deb2c9a  subversion-1.3.0.tar.gz
  7d93be2bc70d046ddd1301ae82b166de  subversion-1.3.0.zip

The SHA1 checksums are:

  0c5c4acfbd576da39cd60450f3e16b81c3d7c209  subversion-1.3.0.tar.bz2
  98cb017844750d4ed26e2a811c581a644e3ad585  subversion-1.3.0.tar.gz
  7d1f3a5f741d7eed069cf36ec029e59049ce1be1  subversion-1.3.0.zip

PGP Signatures are available at:

  http://subversion.tigris.org/downloads/subversion-1.3.0.tar.gz.asc
  http://subversion.tigris.org/downloads/subversion-1.3.0.tar.bz2.asc
  http://subversion.tigris.org/downloads/subversion-1.3.0.zip.asc

For this release, the following people have provided PGP signatures:

   Erik Huelsmann [1024D/96B3F539] with fingerprint:
    261D D45F EBBA 0993 2693  3CCB 8B93 B412 96B3 F539
   Garrett Rooney [1024D/9BCFCE2F] with fingerprint:
    075F EDE9 4293 944E 4B56  F75C C91D B8DA 9BCF CE2F
   Daniel J. Berlin [1024D/51E507AC] with fingerprint:
    DAD6 3E94 EBF8 A39A A0AF  E193 EC59 A047 51E5 07AC
   Mark Phippard [2048R/7DD66767] with fingerprint:
    EAF4 5239 AF08 D762 539A  13D5 159E 3781 7DD6 6767
   D.J. Heap [1024D/F6254D87] with fingerprint:
    5F17 7F74 C736 CE57 FD2D  4B84 127F 923C F625 4D87
   David Anderson [1024D/EE506461] with fingerprint:
    21DF EE01 0E07 B970 CBD1  F75A 09BC 35E3 EE50 6461
   Jani Averbach [1024D/16D8B41C] with fingerprint:
    3A1F 5A74 ADF2 5B0C 62E2  1F6A D6C6 2497 16D8 B41C
   Ben Collins-Sussman [1024D/EC6B5156] with fingerprint:
    9FBF BEB7 409D D55F 6946  5CC6 5348 1A68 EC6B 5156

Subversion 1.3.0 is the first new feature release since 1.2.0 and includes
a  number of new improvements and features.  The changes between 1.2.3 and
1.3.0  are listed below.  You can also find a detailed list of the changes
in our  release notes at:

  http://subversion.tigris.org/svn_1.3_releasenotes.html 

Questions, comments, and bug reports to users@subversion.tigris.org.

Thanks,
- The Subversion Team

--------------------8-<-------cut-here---------8-<-----------------------
 User-visible-changes:
  - Client:
    * 'svn ls -v' now shows remote locks (issue #2291)
    * 'svn status' speedup (r15061, r15103)
    * 'svn blame' speedup on files with long history (issue #1970)
    * 'svnversion' now assumes default argument of '.' (r14892)
    * support for neon 0.25.x, which fixes http:// control-c bug (issue
#2297)     * support for more ISO-8601 date formats, compatible with GNU
date  (r14428)
    * support for single-digit date components (r15459)
    * on Windows, '_svn' admin dir now toggled by runtime env. variable 
(r16244)
    * working copy size with empty propfiles reduced (r16855, see 
releasenotes)
    * new switches added:
       - 'svn blame --xml [--incremental]' (r14690)
       - 'svn status --xml [--incremental]'  (issue #2069)
       - 'svn info --xml [--incremental]'
       - 'svn add/import --no-ignore'  (issue #2105)
       - 'svnlook tree --full-paths'  (r13976)
       - 'svnlook diff --diff-copy-from'  (r14855)
       - 'svnlook changed --copy-info' (r16681)
    * fixed: 'svn copy wc URL' might include deleted items (issue #2153)
    * fixed: 'svn copy wc wc' allows cross-repository copies (issue #2404)
    * fixed: 'svn up/merge' major property-merging bugs (issue #2035)
    * fixed: 'svn merge' insisting on write access to '.' (issue #2411)
    * fixed: 'svn merge' cross-device move problems (r16293, -329, -330)
    * fixed: 'svn diff' outputs headers in wrong encoding (issue #1533)
    * fixed: 'svn proplist/add/cat' dies on unversioned items (issue #2030)
    * fixed: 'svn add' not honoring svn:ignore property (issue #2243)
    * fixed: 'svn log -rN:M --limit X' error over http:// (issue #2396)
    * fixed: 'svn switch --relocate' failure on 'deleted' dir (r16673)
    * fixed: 'svn info' not always showing repos lock (issue #2276)
    * fixed: 'svn info' might show lock on wrong path (r16626)
    * fixed: 'svnlook' chokes on logs with inconsistent newlines (r14573)
    * fixed: 'svnlook propget --revprop -t' failure (r15203)
    * fixed: 'svnversion' wrongly traverses into externals (r15161)
    * fixed: incorrect URI encoding passed to svn+ssh:// (issue #2406)
    * fixed: properly handle filenames containing '@' (issue #2317)
    * fixed: '--non-interactive' now suppresses launch of $EDITOR (r15277)
    * fixed: conflict markers not in current encoding (r14621)
    * fixed: commands ignoring extraneous -m or -F switches (issue #2285)
    * fixed: poor error-checking when using revprops (r15542)
    * fixed: stack-smashing bugs (r15948, r16037)
    * fixed: incorrect parsing of mod_dav_svn XML responses (r17589)
    * translation updates for all languages

  - Server:
    * svnserve improvements:
       - can now restrict read/write access by path (see releasenotes)
       - undeprecation of the --read-only (-R) option (r17614)
    * mod_dav_svn improvements:
       - 'SVNListParentPath on' shows all repositories in web browser
(r16158)        - ability to log high-level client operations (see
releasenotes)        - sets svn:mime-type on autoversioning commits (r14359)
    * 'svn log' performance improvement (r14722)
    * fixed: fs history algorithm might return wrong objects (issue #1970)
    * fixed: repos deadlock when hooks output too much (issue #2078)
    * fixed: mod_dav_svn displays errors with sensitive paths (r14792)
    * fixed: anonymous reader could create empty commits (issue #2388)
    * fixed: possible segfault to callers of trace_node_locations() (r16188)
    * fixed: BDB-style locking actions on FSFS repositories (r16295, r16297)
    * fixed: numerous bugs running BDB commands on FSFS (issue #2361,
r16388)     * fixed: svndumpfilter incorrectly remapping dropped revs
(issue #1911)

  - Both:
    * faster multiple (un)locks in a single svn:// request (issue #2264)
    * the Subversion Book is no longer bundled (r17466)

Developer-visible-changes:
* reorganization of automated tests, including ability to run on ramdisk
* lots of Doxygen/API documentation cleanup
* numerous improvements to gen-make.py build system, especially on win32
* working copy is now storing repos_root as separate field (issue #960)
* keywords are now stored in an internal hash (issue #890)
* client status APIs now makes more server-side info available (r16344)
* new public APIs:  
   - new transfer progress callback for DAV (r15948)
   - svn_ra_initialize(), svn_client_open_ra_session()
   - svn_fs_closest_copy(), svn_fs_type()
   - several rev'd APIs, see doxygen docs
* SWIG bindings: No more compile-time or runtime SWIG dependencies
    - SWIG/python bindings:
       - automatic memory management: APIs no longer require pool arguments!
       - improved stability, as shown by our new testsuite
       - better error messages
    - SWIG/ruby bindings:
       - complete API coverage!
       - automatic memory management
       - greatly expanded test suite
    - SWIG/perl bindings:
       - new accessors for svn_lock_t, svn_fs_access_t
       - a number of bugfixes
* javahl bindings:
    - add streamy API for fetching file contents (r15584) 
    - fixed: let tests run before bindings are installed (issue #2040)
    - fixed: lock command not raising errors properly (issue #2394)
    - fixed: ignored errors from svn_client_blame2() (r16434)

---------- End Forwarded Message ----------
Comment 1 Joe Orton 2006-01-04 07:32:22 EST
*** Bug 176880 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.