Bug 1768339 - glusterfsd memory leak observed after enable tls
Summary: glusterfsd memory leak observed after enable tls
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
: 1707227 (view as bug list)
Depends On:
Blocks: 1785577 1708047 1768407 1795609 1804515
TreeView+ depends on / blocked
 
Reported: 2019-11-04 06:35 UTC by zhou lin
Modified: 2020-03-12 12:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1768407 (view as bug list)
Environment:
Last Closed: 2020-03-12 12:26:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description zhou lin 2019-11-04 06:35:00 UTC
Description of problem:

glusterfsd process memory leak dramatically after enable tls
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.while true; do gluster v heal <vol-name> info;done
2.top to observe glusterfsd memory usage
3.memory usage increase steadily

Actual results:

memory increase until oom
Expected results:


Additional info:

Comment 1 Worker Ant 2019-11-04 11:30:42 UTC
REVISION POSTED: https://review.gluster.org/23650 (rpc: Cleanup SSL specific data at the time of freeing rpc object) posted (#4) for review on master by MOHIT AGRAWAL

Comment 2 Xavi Hernandez 2020-01-27 10:53:52 UTC
*** Bug 1707227 has been marked as a duplicate of this bug. ***

Comment 3 Worker Ant 2020-03-12 12:26:56 UTC
This bug is moved to https://github.com/gluster/glusterfs/issues/890, and will be tracked there from now on. Visit GitHub issues URL for further details


Note You need to log in before you can comment on or make changes to this bug.