Bug 1768407 - glusterfsd memory leak observed after enable tls
Summary: glusterfsd memory leak observed after enable tls
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
: 1708047 (view as bug list)
Depends On: 1768339
Blocks: 1785577 1795609 1804515
TreeView+ depends on / blocked
 
Reported: 2019-11-04 11:27 UTC by Mohit Agrawal
Modified: 2020-02-19 03:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1768339
: 1785577 1795609 1804515 (view as bug list)
Environment:
Last Closed: 2019-11-08 01:32:07 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 23650 None Merged rpc: Cleanup SSL specific data at the time of freeing rpc object 2019-11-08 01:32:06 UTC

Description Mohit Agrawal 2019-11-04 11:27:58 UTC
+++ This bug was initially created as a clone of Bug #1768339 +++

Description of problem:

glusterfsd process memory leak dramatically after enable tls
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.while true; do gluster v heal <vol-name> info;done
2.top to observe glusterfsd memory usage
3.memory usage increase steadily

Actual results:

memory increase until oom
Expected results:


Additional info:

Comment 1 Worker Ant 2019-11-04 11:30:46 UTC
REVIEW: https://review.gluster.org/23650 (rpc: Cleanup SSL specific data at the time of freeing rpc object) posted (#4) for review on master by MOHIT AGRAWAL

Comment 2 Worker Ant 2019-11-08 01:32:07 UTC
REVIEW: https://review.gluster.org/23650 (rpc: Cleanup SSL specific data at the time of freeing rpc object) merged (#5) on master by Raghavendra G

Comment 3 Xavi Hernandez 2020-01-27 10:52:38 UTC
*** Bug 1708047 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.