Bug 1785577 - gluster processes are having memory leak after enabling SSL
Summary: gluster processes are having memory leak after enabling SSL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rpc
Version: rhgs-3.5
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: RHGS 3.5.z Batch Update 3
Assignee: Mohit Agrawal
QA Contact: Sayalee
URL:
Whiteboard:
Depends On: 1768339 1768407 1795609 1804515
Blocks: 1848891
TreeView+ depends on / blocked
 
Reported: 2019-12-20 10:38 UTC by Sanju
Modified: 2021-01-27 06:31 UTC (History)
19 users (show)

Fixed In Version: glusterfs-6.0-38
Doc Type: No Doc Update
Doc Text:
Clone Of: 1768407
: 1848891 (view as bug list)
Environment:
Last Closed: 2020-12-17 04:50:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5603 0 None None None 2020-12-17 04:51:35 UTC

Description Sanju 2019-12-20 10:38:09 UTC
+++ This bug was initially created as a clone of Bug #1768407 +++

+++ This bug was initially created as a clone of Bug #1768339 +++

Description of problem:

glusterfsd process memory leak dramatically after enable tls
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.while true; do gluster v heal <vol-name> info;done
2.top to observe glusterfsd memory usage
3.memory usage increase steadily

Actual results:

memory increase until oom
Expected results:


Additional info:

--- Additional comment from Worker Ant on 2019-11-04 17:00:46 IST ---

REVIEW: https://review.gluster.org/23650 (rpc: Cleanup SSL specific data at the time of freeing rpc object) posted (#4) for review on master by MOHIT AGRAWAL

--- Additional comment from Worker Ant on 2019-11-08 07:02:07 IST ---

REVIEW: https://review.gluster.org/23650 (rpc: Cleanup SSL specific data at the time of freeing rpc object) merged (#5) on master by Raghavendra G

Comment 41 Bipin Kunal 2020-03-17 04:55:08 UTC
*** Bug 1811041 has been marked as a duplicate of this bug. ***

Comment 72 errata-xmlrpc 2020-12-17 04:50:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (glusterfs bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5603


Note You need to log in before you can comment on or make changes to this bug.