Bug 1769008 - Missing openapi CRD definitions for oc explain to work
Summary: Missing openapi CRD definitions for oc explain to work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks: 1769621 1785302
TreeView+ depends on / blocked
 
Reported: 2019-11-05 18:18 UTC by Maciej Szulik
Modified: 2020-05-04 11:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1785302 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 519 0 'None' closed Bug 1769008: Migrating imageregistry api definitions. 2020-05-27 09:42:39 UTC
Github openshift api pull 537 0 'None' closed Bug 1769008: Adding missing Azure container name validation. 2020-05-27 09:42:39 UTC
Github openshift api pull 546 0 None closed Bug 1769008: Add missing preserveUnknownFields tags 2020-05-27 09:42:39 UTC
Github openshift client-go pull 123 0 'None' closed Bug 1769008: Importing new "imageregistry" and "samples" types from openshift/api 2020-05-27 09:42:40 UTC
Github openshift cluster-image-registry-operator pull 415 0 None closed Bug 1769008: Switch to client-go 2020-05-27 09:42:43 UTC
Github openshift cluster-image-registry-operator pull 417 0 None closed Bug 1769008: Bumping openshift/api. 2020-05-27 09:42:41 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:15:11 UTC

Description Maciej Szulik 2019-11-05 18:18:03 UTC
The following PR https://github.com/openshift/origin/pull/22696 introduced an e2e which is verifying that all the operators provide descriptive information as part of their schema which is then available through oc explain command. 
This was recently updated and brought back in https://github.com/openshift/origin/pull/24058. 

Your component has a few missing bits, see the commented out lines from the PR.

This should be fixed similarly to https://github.com/openshift/cluster-kube-controller-manager-operator/pull/302, 
iow. it should be using openshift/api's generated CRD yamls. 

Once done update origin's e2e test and uncomment the lines from your components.

Comment 2 Adam Kaplan 2019-11-12 14:00:51 UTC
*** Bug 1769621 has been marked as a duplicate of this bug. ***

Comment 4 Adam Kaplan 2019-11-22 18:35:31 UTC
API changes landed in 4.3, but client-go has not landed yet.

@Ricardo at this point it may be easier to keep the existing client in the image registry operator repo, and merely regenerate it by bumping openshift/api. Keep in mind that we will want to backport this change to the release-4.3 branch.

Comment 7 Wenjing Zheng 2019-12-16 08:12:34 UTC
[wzheng@openshift-qe 4.4]$ ./oc version
Client Version: v4.4.0
Server Version: 4.4.0-0.nightly-2019-12-15-184910
Kubernetes Version: v1.16.2
[wzheng@openshift-qe 4.4]$ ./oc explain configs --api-version=imageregistry.operator.openshift.io/v1
KIND:     Config
VERSION:  imageregistry.operator.openshift.io/v1

DESCRIPTION:
     <empty>
[wzheng@openshift-qe 4.4]$ ./oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2019-12-15-184910   True        False         6h55m   Cluster version is 4.4.0-0.nightly-2019-12-15-184910

I still cannot see the fix, so assign back.

Comment 9 XiuJuan Wang 2019-12-25 01:18:43 UTC
Test with 4.4.0-0.nightly-2019-12-20-210709 payload, and pass
$oc version 
Client Version: v4.3.0
Server Version: 4.4.0-0.nightly-2019-12-20-210709
Kubernetes Version: v1.17.0

$oc explain configs --api-version=imageregistry.operator.openshift.io/v1
KIND:     Config
VERSION:  imageregistry.operator.openshift.io/v1

DESCRIPTION:
     Config is the configuration object for a registry instance managed by the
     registry operator

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object> -required-
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object> -required-
     ImageRegistrySpec defines the specs for the running registry.

   status	<Object>
     ImageRegistryStatus reports image registry operational status.

Comment 11 errata-xmlrpc 2020-05-04 11:14:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.