Bug 1785302 - [4.3] Missing openapi CRD definitions for oc explain to work
Summary: [4.3] Missing openapi CRD definitions for oc explain to work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.z
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
: 1769621 (view as bug list)
Depends On: 1769008
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-19 16:13 UTC by Oleg Bulatov
Modified: 2020-03-10 23:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1769008
Environment:
Last Closed: 2020-03-10 23:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 424 None closed Bug 1785302: Using types from openshift/api repository. 2020-06-19 09:51:28 UTC
Red Hat Product Errata RHBA-2020:0676 None None None 2020-03-10 23:53:09 UTC

Comment 1 Oleg Bulatov 2020-01-07 21:16:06 UTC
*** Bug 1769621 has been marked as a duplicate of this bug. ***

Comment 4 Wenjing Zheng 2020-02-21 02:44:28 UTC
zhengwenjings-MacBook-Pro:4.3 wzheng$ ./oc explain configs --api-version=imageregistry.operator.openshift.io/v1
KIND:     Config
VERSION:  imageregistry.operator.openshift.io/v1

DESCRIPTION:
     Config is the configuration object for a registry instance managed by the
     registry operator

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object> -required-
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object> -required-
     ImageRegistrySpec defines the specs for the running registry.

   status	<Object>
     ImageRegistryStatus reports image registry operational status.

zhengwenjings-MacBook-Pro:4.3 wzheng$ ./oc version
Client Version: v4.3.3
Server Version: 4.3.0-0.nightly-2020-02-20-190050
Kubernetes Version: v1.16.2
zhengwenjings-MacBook-Pro:4.3 wzheng$ ./oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-0.nightly-2020-02-20-190050   True        False         79m     Cluster version is 4.3.0-0.nightly-2020-02-20-190050

Comment 6 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.