Bug 1769621 - [4.3] Missing openapi CRD definitions when try to explain configs.imageregistry.operator.openshift.io
Summary: [4.3] Missing openapi CRD definitions when try to explain configs.imageregist...
Keywords:
Status: CLOSED DUPLICATE of bug 1785302
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On: 1769008
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 02:55 UTC by Wenjing Zheng
Modified: 2020-01-07 21:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-07 21:16:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2019-11-07 02:55:28 UTC
This bug was initially created as a copy of Bug #1769167

I am copying this bug because: 



This bug was initially created as a copy of Bug #1708600

I am copying this bug because: 



+++ This bug was initially created as a clone of Bug #1708597 +++

Description of problem:
Copied from bug 1705746, should add the description info for these CRDs so that `oc explain` can work when try to explain configs.imageregistry.operator.openshift.io crd:
$ oc explain configs.imageregistry.operator.openshift.io |grep -i description -A 3
DESCRIPTION:
     <empty>
$ oc explain configs.samples.operator.openshift.io 
KIND:     Config
VERSION:  imageregistry.operator.openshift.io/v1

DESCRIPTION:
     <empty>


Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-02-092336

How reproducible:
Always

Steps to Reproduce:
1.$ oc explain configs.imageregistry.operator.openshift.io
2.$ oc explain configs.samples.operator.openshift.io 
3.$ oc explain openshiftcontrollermanagers

Actual results:
Get nothing about the description.

Expected results:
Should get the appropriate description.

Additional info:

Comment 1 Adam Kaplan 2019-11-12 14:00:51 UTC

*** This bug has been marked as a duplicate of bug 1769008 ***

Comment 2 Wenjing Zheng 2020-01-06 09:27:36 UTC
This bug is to fix on 4.4: https://bugzilla.redhat.com/show_bug.cgi?id=1769008 , so re-open this bug to have a fix on 4.3.z.

Comment 4 Oleg Bulatov 2020-01-07 21:16:06 UTC

*** This bug has been marked as a duplicate of bug 1785302 ***


Note You need to log in before you can comment on or make changes to this bug.