Bug 1775864 - topology: changing operations while dragging using the shift button causes node to jump out of position
Summary: topology: changing operations while dragging using the shift button causes no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1776346 1776474
TreeView+ depends on / blocked
 
Reported: 2019-11-23 02:36 UTC by cvogt
Modified: 2020-05-04 11:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When the user switches between drag move and drag regroup modes, the node position was being reset. Consequence: When the user switches between drag move and drag regroup modes, the node would jump back to the original position offset from the user's mouse making the interaction difficult to use. Fix: When switching modes, the node position is no longer reset. Result: Switching between drag move and drag regroup modes now maintains the correct node position.
Clone Of:
: 1776346 1776474 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
jumping node (1.86 MB, image/gif)
2019-11-23 02:36 UTC, cvogt
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3539 0 'None' closed Bug 1775864: use actionAsync when calling dndManager#endDrag 2020-04-22 13:35:05 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:17:26 UTC

Description cvogt 2019-11-23 02:36:30 UTC
Created attachment 1638958 [details]
jumping node

Description of problem:
In topology.
When you change drag operations using the shift button, the node should remain under the mouse however it is jumping back to an older position.

The same bug is causing at times the regroup operation when holding shift to not even start.

Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%


Steps to Reproduce:
1. in topology start dragging a deployment config node
2. hold shift button and drag the node some more
3. release the shift button

Actual results:
When the shift button is released, the node jumps back to the position where the shift button was first pressed. Continuing to drag shows a disconnected gap between the mouse and the node


Expected results:
The node should remain under the mouse at all times.


Additional info:
This is related to a brand new feature ini 4.3.

Comment 2 Ruchir Garg 2020-03-02 06:38:32 UTC
Bulk assigning all to Gajanan for verification.

Comment 3 Gajanan More 2020-03-03 13:04:13 UTC
I have validated this bug on 
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 5 errata-xmlrpc 2020-05-04 11:16:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.