Bug 1776474 - topology: changing operations while dragging using the shift button causes node to jump out of position
Summary: topology: changing operations while dragging using the shift button causes no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
: 1776346 (view as bug list)
Depends On: 1775864
Blocks: 1776346
TreeView+ depends on / blocked
 
Reported: 2019-11-25 18:18 UTC by Jeff Phillips
Modified: 2020-01-23 11:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1775864
Environment:
Last Closed: 2020-01-23 11:14:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3569 0 'None' 'closed' '[release-4.3] Bug 1776474: use actionAsync when calling dndManager#endDrag' 2019-12-02 21:19:46 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:14:31 UTC

Comment 2 cvogt 2019-12-02 21:20:57 UTC
Description of problem:
In topology.
When you change drag operations using the shift button, the node should remain under the mouse however it is jumping back to an older position.

The same bug is causing at times the regroup operation when holding shift to not even start.

Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%


Steps to Reproduce:
1. in topology start dragging a deployment config node
2. hold shift button and drag the node some more
3. release the shift button

Actual results:
When the shift button is released, the node jumps back to the position where the shift button was first pressed. Continuing to drag shows a disconnected gap between the mouse and the node


Expected results:
The node should remain under the mouse at all times.


Additional info:
This is related to a brand new feature ini 4.3.

Comment 3 cvogt 2019-12-02 21:21:49 UTC
*** Bug 1776346 has been marked as a duplicate of this bug. ***

Comment 4 Ruchir Garg 2020-01-07 09:57:17 UTC
Assigning defect to Gajanan More for verification.

Comment 5 Gajanan More 2020-01-07 11:14:50 UTC
I have validated the bug on the cluster with
Build: 4.3.0-0.nightly-2020-01-06-185654
Browser: Chrome Version 78.0.3904.108

Comment 7 errata-xmlrpc 2020-01-23 11:14:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.