Bug 1776346 - topology: changing operations while dragging using the shift button causes node to jump out of position
Summary: topology: changing operations while dragging using the shift button causes no...
Keywords:
Status: CLOSED DUPLICATE of bug 1776474
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On: 1775864 1776474
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-25 14:09 UTC by Jeff Phillips
Modified: 2019-12-02 21:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1775864
Environment:
Last Closed: 2019-12-02 21:21:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jeff Phillips 2019-11-25 14:09:52 UTC
+++ This bug was initially created as a clone of Bug #1775864 +++

Description of problem:
In topology.
When you change drag operations using the shift button, the node should remain under the mouse however it is jumping back to an older position.

The same bug is causing at times the regroup operation when holding shift to not even start.

Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%


Steps to Reproduce:
1. in topology start dragging a deployment config node
2. hold shift button and drag the node some more
3. release the shift button

Actual results:
When the shift button is released, the node jumps back to the position where the shift button was first pressed. Continuing to drag shows a disconnected gap between the mouse and the node


Expected results:
The node should remain under the mouse at all times.


Additional info:
This is related to a brand new feature ini 4.3.

Comment 1 cvogt 2019-12-02 21:21:49 UTC

*** This bug has been marked as a duplicate of bug 1776474 ***


Note You need to log in before you can comment on or make changes to this bug.