Bug 177592 - beagled go boom on startup.
beagled go boom on startup.
Status: CLOSED DUPLICATE of bug 179228
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 177887 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 19:20 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 11:13:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 177749 None None None Never

  None (edit)
Description Dave Jones 2006-01-11 19:20:42 EST
Description of problem:

(19:21:22:davej@nwo:2.6.16)$ beagled
(19:21:27:davej@nwo:2.6.16)$
=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in <0xffffffffffffffff> Beagle.Daemon.Server:Run ()
in <0x223> Beagle.Daemon.Server:Run ()
in <0x166> (wrapper delegate-invoke) System.MulticastDelegate:invoke_void ()
in <0x3e> Beagle.Util.ExceptionHandlingThread:ThreadStarted ()
in <0xffffffffffffff7e> (wrapper delegate-invoke)
System.MulticastDelegate:invoke_void ()
in <0xffffffffc01ffc42> (wrapper runtime-invoke)
System.Object:runtime_invoke_void (object,intptr,intptr,intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4f1711]
        mono-beagled [0x4c0210]
        /lib64/libpthread.so.0 [0x3c3dd0cbe0]
        /usr/lib64/libglib-2.0.so.0(g_hash_table_lookup+0x65) [0x3c3c21a64d]
        mono-beagled(mono_find_jit_icall_by_addr+0x22) [0x4637f3]
        mono-beagled [0x423fc2]
        mono-beagled(mono_arch_output_basic_block+0x6c67) [0x430549]
        mono-beagled(mono_codegen+0x98) [0x4c262c]
        mono-beagled [0x4ddbae]
        mono-beagled [0x4de8e9]
        mono-beagled(mono_magic_trampoline+0x1b) [0x4f4d36]
        [0x4000013a]

Version-Release number of selected component (if applicable):
beagle-0.1.4-2

How reproducible:
every time

Steps to Reproduce:
1. install beagle to see what the fuss is about
2. try to run it
3. fail to be wowed.
  
Expected results: joy!

Actual results: Much sadness.

Additional info: I'm having a burrito for dinner.
Comment 1 Dave Jones 2006-01-12 15:35:56 EST
I blew away my ~/.beagle from an ancient install, and ran again with todays
updates. different behaviour...

(15:38:50:davej@nwo:~)$ beagled --fg --debug
Debug: Starting Beagle Daemon (version 0.1.4)
Debug: Command Line: /usr/lib64/beagle/BeagleDaemon.exe --fg --debug
Warn: Extended attributes are not supported on this filesystem.  Many search
backends will not be available
Debug: Starting main loop
Debug: Starting messaging server
Debug: Starting QueryDriver
Debug: Found index helper at /usr/lib64/beagle/beagled-index-helper
Debug: Found 1 types in EvolutionDataServer, Version=0.0.0.0, Culture=neutral
Debug: Guessing for location of KMail folders ... found at /home/davej/Mail
Debug: Starting Inotify Backend
Debug: Scanning for files in the IndexingService directory...
Debug: Indexed 0 Indexing Service items in .00s
Debug: Found 12 types in BeagleDaemonLib, Version=1.9.0.0, Culture=neutral
Debug: Initializing static queryable: /var/cache/beagle/indexes/applications
Debug: Initializing static queryable: /var/cache/beagle/indexes/documentation
Debug: Initializing static queryable: /var/cache/beagle/indexes/windows
Debug: Found 3 system-wide indexes
Debug: Found 0 user-configured static queryables
Debug: Scanning addressbooks and calendars
Debug: Getting addressbook changes for
file:///home/davej/.evolution/addressbook/local/system
Debug: Addressbook file:///home/davej/.evolution/addressbook/local/system: 0
added, 0 changed, 0 removed
Debug: Getting calendar changes for
file:///home/davej/.evolution/calendar/local/system
Debug: Calendar file:///home/davej/.evolution/calendar/local/system: 0 added, 0
changed, 0 removed
Debug: Getting calendar changes for
webcal://fedora.redhat.com/About/schedule/fedora-project.ics
Debug: Calendar webcal://fedora.redhat.com/About/schedule/fedora-project.ics: 0
added, 0 changed, 0 removed
Warn: Unable to open calendar contacts:///: glibsharpglue
Debug: Getting calendar changes for
file:///home/davej/.evolution/calendar/local/system
Debug: Calendar file:///home/davej/.evolution/calendar/local/system: 0 added, 0
changed, 0 removed
Debug: Scanned addressbooks and calendars in .38s
Debug: Starting Evolution mail backend
Debug: Starting mail crawl
Debug: Adding root: /home/davej
Debug: Starting KMail backend
Debug: Starting mail crawl
Debug: mail_directories created for:/home/davej/Mail (0)
Debug: Searching for mbox and maildirs in /home/davej/Mail
Debug: Mail crawl done
Debug: KMail driver worker thread done in .01s

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in <0xb> (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)
in <0xfffffffffffff957> (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)
in <0x197> Mono.Data.SqliteClient.SqliteDataReader:ReadNextColumn ()
in <0x10> Mono.Data.SqliteClient.SqliteDataReader:Read ()
in <0xffffffffffffff7f> (wrapper remoting-invoke-with-check)
Mono.Data.SqliteClient.SqliteDataReader:Read ()
in <0x27> Beagle.Daemon.FileAttributesStore_Sqlite:ReadOrWait
(Mono.Data.SqliteClient.SqliteDataReader)
in <0x1f7> Beagle.Daemon.FileAttributesStore_Sqlite:.ctor (string,string)
in <0x5e> Beagle.Daemon.FileAttributesStore_Mixed:.ctor (string,string)
in <0x44>
Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:BuildFileAttributesStore ()
in <0x2d> Beagle.Daemon.LuceneQueryable:get_FileAttributesStore ()
in <0x1ba> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:AddDirectory
(Beagle.Daemon.FileSystemQueryable.DirectoryModel,string)
in <0x11a> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:AddRoot (string)
in <0x66> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:LoadConfiguration ()
in <0x3d> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:Start ()
in <0x22> Beagle.Daemon.Queryable:Start ()
in <0xef> Beagle.Daemon.QueryDriver:Start ()
in <0x1c7> Beagle.Daemon.BeagleDaemon:StartupProcess ()
in <0xffffffffffffff85> (wrapper delegate-invoke)
System.MulticastDelegate:invoke_bool ()
in <0x45> IdleProxy:Handler ()
in <0x3b8db6d6> (wrapper native-to-managed) IdleProxy:Handler ()
in <0xb> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0xffffffffffffffd0> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x8> Gtk.Application:Run ()
in <0x6d2> Beagle.Daemon.BeagleDaemon:DoMain (string[])
in <0x1c> Beagle.Daemon.BeagleDaemon:Main (string[])
in <0xffffffffc04370bf> (wrapper runtime-invoke)
System.Object:runtime_invoke_void_string[] (object,intptr,intptr,intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4f1711]
        mono-beagled [0x4c0210]
        /lib64/libpthread.so.0 [0x3c3dd0cbe0]
        mono-beagled(mono_string_new+0x2a) [0x44ea71]
        [0x41d5ec2b]
Aborted (core dumped)
Comment 2 Dave Jones 2006-01-13 01:36:39 EST
more curious stuff.  I blew away my ~/.beagle again, and reran the above.
This time it started indexing stuff.
Until it got to my Mail folder.. then this happened...

Debug: Saw event in '/home/davej/Mail'
Debug: *** Add '/home/davej/Mail' '.msgid.cache' (file)
Debug: *** Remove '/home/davej' 'msgid.lock' (file)
Warn: Could resolve unique id of 'msgid.lock' in '/home/davej' for removal, it
is probably already gone
Debug: Saw event in '/home/davej/Mail'
Debug: *** Add '/home/davej/Mail' 'mbox-January-2006' (file)
Debug: Saw event in '/home/davej/Mail'
Debug: *** Add '/home/davej/Mail' 'log' (file)
Debug: -file:///home/davej/Mail/mbox-January-2006
Debug: +file:///home/davej/Mail/mbox-January-2006
Debug: -file:///home/davej/Mail/log
Debug: +file:///home/davej/Mail/log
Debug: No filter for /home/davej/Mail/log
Debug: *** Add '/home/davej' '_zhE.rq0xDB.nwo' (file)
Debug: *** Remove '/home/davej' '_zhE.rq0xDB.nwo' (file)
Warn: Could resolve unique id of '_zhE.rq0xDB.nwo' in '/home/davej' for removal,
it is probably already gone
Debug: Saw event in '/home/davej/Mail'
Debug: *** Add '/home/davej/Mail' '.msgid.cache' (file)
Debug: *** Remove '/home/davej' 'msgid.lock' (file)
Warn: Could resolve unique id of 'msgid.lock' in '/home/davej' for removal, it
is probably already gone
Debug: Saw event in '/home/davej/Mail'
Debug: *** Add '/home/davej/Mail' 'mbox-January-2006' (file)

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in <0xb> (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4f1711]
        mono-beagled [0x4c0210]
        /lib64/libpthread.so.0 [0x3c3dd0cbe0]
        mono-beagled(mono_string_new+0x2a) [0x44ea71]
        [0x4050f085]
Debug: The daemon appears to have gone away.
Debug: Shutting down helper.
Aborted (core dumped)
Debug: (1) Waiting for 1 worker...
Debug: waiting for server '/home/davej/.beagle/socket-helper'
Debug: Server '/home/davej/.beagle/socket-helper' shut down
Debug: Exiting
Comment 3 Alexander Larsson 2006-01-13 03:54:50 EST
Maybe this is 64bit (x86-64) issues.
Comment 4 Dave Jones 2006-01-17 12:07:23 EST
*** Bug 177887 has been marked as a duplicate of this bug. ***
Comment 5 Christopher Aillon 2006-02-09 11:13:32 EST

*** This bug has been marked as a duplicate of 179228 ***

Note You need to log in before you can comment on or make changes to this bug.