Bug 177749 - beagled causes SEGV on startup
beagled causes SEGV on startup
Status: CLOSED DUPLICATE of bug 177887
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-13 12:45 EST by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 09:15:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 177592 None None None Never

  None (edit)
Description Andy Burns 2006-01-13 12:45:10 EST
Description of problem:

beagled has warning about missing evolution DLLs then SEGVs

Version-Release number of selected component (if applicable):

beagle 0.1.4-3

How reproducible:

always

Steps to Reproduce:
1. rm -rf ~/.beagled
2. beagled --fg --debug
  
Actual results:

Debug: Starting Beagle Daemon (version 0.1.4)
Debug: Command Line: /usr/lib64/beagle/BeagleDaemon.exe --fg --debug
Warn: Extended attributes are not supported on this filesystem.  Many search
backends will not be available
Debug: Starting main loop
Debug: Starting messaging server
Debug: Starting QueryDriver

** (beagled:4498): WARNING **: The following assembly referenced from
/usr/lib64/beagle/Backends/EvolutionDataServer.dll could not be loaded:
     Assembly:   evolution-sharp    (assemblyref_index=1)
     Version:    2.0.0.0
     Public Key: 457eed85bd9370df
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib64/beagle/Backends).


** (beagled:4498): WARNING **: The class Evolution.Source could not be loaded,
used in evolution-sharp, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=457eed85bd9370df
Debug: Found index helper at /usr/lib64/beagle/beagled-index-helper
Debug: Found 1 types in EvolutionDataServer, Version=0.0.0.0, Culture=neutral
Debug: KMail folders not found. Will keep trying
Debug: Starting Inotify Backend
Debug: Scanning for files in the IndexingService directory...
Debug: Indexed 0 Indexing Service items in .00s
Debug: Found 12 types in BeagleDaemonLib, Version=1.9.0.0, Culture=neutral
Debug: Initializing static queryable: /var/cache/beagle/indexes/applications
Debug: Initializing static queryable: /var/cache/beagle/indexes/documentation
Debug: Initializing static queryable: /var/cache/beagle/indexes/windows
Debug: Found 3 system-wide indexes
Debug: Found 0 user-configured static queryables
Debug: Scanning addressbooks and calendars

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in <0xffffffffffffffff>
Beagle.Daemon.EvolutionDataServerQueryable.EvolutionDataServerQueryable:Start ()
in <0x107>
Beagle.Daemon.EvolutionDataServerQueryable.EvolutionDataServerQueryable:Start ()
in <0x22> Beagle.Daemon.Queryable:Start ()
in <0xef> Beagle.Daemon.QueryDriver:Start ()
in <0x1c7> Beagle.Daemon.BeagleDaemon:StartupProcess ()
in <0xffffffffffffff85> (wrapper delegate-invoke)
System.MulticastDelegate:invoke_bool ()
in <0x45> IdleProxy:Handler ()
in <0xffffffffb46b3b76> (wrapper native-to-managed) IdleProxy:Handler ()
in <0xb> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0xffffffffffffffd0> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x8> Gtk.Application:Run ()
in <0x6d2> Beagle.Daemon.BeagleDaemon:DoMain (string[])
in <0x1c> Beagle.Daemon.BeagleDaemon:Main (string[])
in <0xffffffffc04370bf> (wrapper runtime-invoke)
System.Object:runtime_invoke_void_string[] (object,intptr,intptr,intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4f1711]
        mono-beagled [0x4c0210]
        /lib64/libpthread.so.0 [0x31b340cbe0]
        mono-beagled(mono_class_from_mono_type+0x6) [0x492b4e]
        [0x2aaaafe519d0]
Aborted

Expected results:

beagled starts and builds index?

Additional info:

Saw the warnings about evolution Dlls missing, I had evolutution installed, but
was not using it, so first I ran evolution to let it do any "first time"
initialisation, no different, so then rI emoved evolution and evolution-sharp,
no different, tried to remove evolution-data-server, but the dependencies would
have removed too much other stuff.
Comment 1 Andy Burns 2006-01-13 12:53:11 EST
I cleaned out ~/.beagle and this time also cleaned /var/cache/beagle 

re-ran beagled, and then got the same error as davej in BZ #177592
We both appear to be using x86_64 ...

Comment 2 Andy Burns 2006-01-13 13:23:02 EST
yum removed beagle and libbeagle (which took nautilus with it) then cleaned out

~/.beagle
/var/cache/beagle
/etc/beagle

yum installed beagle nautilus

now beagled starts, and apparently finishes it's indexing

I thought it was including my thunderbird/imap4 folders, 
but it tuns out it is from evolution, which from my earlier tests still points
at the same imap account as thunderbird.

Then it crashed again, after restarting it yet again beagled did stay running
for a while and then best can find emails, but beagled seems to fall over quite
regularly :-(

[...]
Debug: +email://1136931202.7098.19@localhost.localdomain/INBOX/Bugzilla;uid=113
Debug: +email://1136931202.7098.19@localhost.localdomain/INBOX/Bugzilla;uid=114
Debug: +email://1136931202.7098.19@localhost.localdomain/INBOX/Bugzilla;uid=111
Debug: +email://1136931202.7098.19@localhost.localdomain/INBOX/Bugzilla;uid=112
Debug: Overall percent is 78.58334
Debug: INBOX/Bugzilla: indexed 114 messages (114/163 69.9%)
Debug: Helper Size: VmRSS=40.8 MB, size=2.32, 32.9%
Debug: Helper Size: VmRSS=40.8 MB, size=2.32, 32.9%
Debug: Done crawling '/home/andy'

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in <0xb> (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4f1711]
        mono-beagled [0x4c0210]
        /lib64/libpthread.so.0 [0x31b340cbe0]
        mono-beagled(mono_string_new+0x2a) [0x44ea71]
        [0x423b54db]
Debug: The daemon appears to have gone away.
Debug: Shutting down helper.
Aborted
Debug: (1) Waiting for 1 worker...
Debug: waiting for server '/home/andy/.beagle/socket-helper'
Debug: Exiting
Debug: Server '/home/andy/.beagle/socket-helper' shut down

Comment 3 Andy Burns 2006-01-19 09:13:19 EST
SEGV Still occurs 100% for me with beagle/libbeagle 0.1.4-3

$ beagled --fg --debug
Debug: Starting Beagle Daemon (version 0.1.4)
Debug: Command Line: /usr/lib64/beagle/BeagleDaemon.exe --fg --debug
Warn: Extended attributes are not supported on this filesystem.  Many search
backends will not be available
Debug: Starting main loop
Debug: Starting messaging server
Debug: Starting QueryDriver
Debug: Found index helper at /usr/lib64/beagle/beagled-index-helper
Debug: Found 1 types in EvolutionDataServer, Version=0.0.0.0, Culture=neutral
Debug: KMail folders not found. Will keep trying
Debug: Starting Inotify Backend
Debug: Loading Beagle.Util.Conf+SearchingConfig from searching.xml
Debug: Scanning for files in the IndexingService directory...
Debug: Indexed 0 Indexing Service items in .00s
Error: Caught exception while trying to parse Kopete contact list: Document
element did not appear. file:///home/andy/.kde/share/apps/kopete/contactlist.xml
Line 1, position 1.
Debug: Found 12 types in BeagleDaemonLib, Version=1.9.0.0, Culture=neutral
Debug: Initializing static queryable: /var/cache/beagle/indexes/applications
Debug: Initializing static queryable: /var/cache/beagle/indexes/documentation
Debug: Initializing static queryable: /var/cache/beagle/indexes/windows
Debug: Found 3 system-wide indexes
Debug: Found 0 user-configured static queryables
Debug: Scanning addressbooks and calendars
Debug: Getting addressbook changes for
file:///home/andy/.evolution/addressbook/local/system
Debug: Addressbook file:///home/andy/.evolution/addressbook/local/system: 0
added, 0 changed, 0 removed
Debug: Getting calendar changes for
file:///home/andy/.evolution/calendar/local/system
Debug: Calendar file:///home/andy/.evolution/calendar/local/system: 0 added, 0
changed, 0 removed
Debug: Getting calendar changes for contacts:///
Debug: Calendar contacts:///: 0 added, 0 changed, 0 removed
Debug: Scanned addressbooks and calendars in 2.60s
Debug: Starting Evolution mail backend
Debug: Starting mail crawl
Debug: Adding root: /home/andy
Debug: Starting KMail backend
Debug: KMail directories (local mail) /home/andy/.kde/share/apps/kmail/dimap not
found, will repoll.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in <0xb> (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)
in <0xfffffffffffff95f> (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)
in <0x197> Mono.Data.SqliteClient.SqliteDataReader:ReadNextColumn ()
in <0x10> Mono.Data.SqliteClient.SqliteDataReader:Read ()
in <0xffffffffffffff7f> (wrapper remoting-invoke-with-check)
Mono.Data.SqliteClient.SqliteDataReader:Read ()
in <0x27> Beagle.Daemon.FileAttributesStore_Sqlite:ReadOrWait
(Mono.Data.SqliteClient.SqliteDataReader)
in <0x1f2> Beagle.Daemon.FileAttributesStore_Sqlite:.ctor (string,string)
in <0x5e> Beagle.Daemon.FileAttributesStore_Mixed:.ctor (string,string)
in <0x44>
Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:BuildFileAttributesStore ()
in <0x2d> Beagle.Daemon.LuceneQueryable:get_FileAttributesStore ()
in <0x1ba> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:AddDirectory
(Beagle.Daemon.FileSystemQueryable.DirectoryModel,string)
in <0x11a> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:AddRoot (string)
in <0x66> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:LoadConfiguration ()
in <0x3d> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:Start ()
in <0x22> Beagle.Daemon.Queryable:Start ()
in <0xef> Beagle.Daemon.QueryDriver:Start ()
in <0x1c7> Beagle.Daemon.BeagleDaemon:StartupProcess ()
in <0xffffffffffffff85> (wrapper delegate-invoke)
System.MulticastDelegate:invoke_bool ()
in <0x45> IdleProxy:Handler ()
in <0x7f3cbf30> (wrapper native-to-managed) IdleProxy:Handler ()
in <0xb> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0xffffffffffffffd0> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x8> Gtk.Application:Run ()
in <0x6d2> Beagle.Daemon.BeagleDaemon:DoMain (string[])
in <0x1c> Beagle.Daemon.BeagleDaemon:Main (string[])
in <0xffffffffc0476f4a> (wrapper runtime-invoke)
System.Object:runtime_invoke_void_string[] (object,intptr,intptr,intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4eff21]
        mono-beagled [0x4be990]
        /lib64/libpthread.so.0 [0x31b340cbe0]
        mono-beagled(mono_string_new+0x2a) [0x48e8fc]
        [0x41d5b8a3]
Aborted
Comment 4 Andy Burns 2006-01-19 09:15:35 EST

*** This bug has been marked as a duplicate of 177887 ***

Note You need to log in before you can comment on or make changes to this bug.