Bug 177887 - beagled crashes on startup
beagled crashes on startup
Status: CLOSED DUPLICATE of bug 177592
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
: 177749 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-01-16 01:06 EST by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-17 12:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2006-01-16 01:06:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I started beagle, and it said to click on the link to start beagled. I clicked on it and beagle still didn't work. I then tried starting beagle manually on the command line.

This is on a x86_64 install.

[edgan@proton ~]$ beagled
[edgan@proton ~]$
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.


in <0xb> (wrapper managed-to-native) System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)in <0xfffffffffffff957> (wrapper managed-to-native) System.Runtime.InteropServices.Marshal:PtrToStringAnsi (intptr)
in <0x197> Mono.Data.SqliteClient.SqliteDataReader:ReadNextColumn ()
in <0x10> Mono.Data.SqliteClient.SqliteDataReader:Read ()
in <0xffffffffffffff7f> (wrapper remoting-invoke-with-check) Mono.Data.SqliteClient.SqliteDataReader:Read ()
in <0x27> Beagle.Daemon.FileAttributesStore_Sqlite:ReadOrWait (Mono.Data.SqliteClient.SqliteDataReader)
in <0x1f7> Beagle.Daemon.FileAttributesStore_Sqlite:.ctor (string,string)
in <0x5e> Beagle.Daemon.FileAttributesStore_Mixed:.ctor (string,string)
in <0x44> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:BuildFileAttributesStore ()
in <0x2d> Beagle.Daemon.LuceneQueryable:get_FileAttributesStore ()
in <0x1ba> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:AddDirectory (Beagle.Daemon.FileSystemQueryable.DirectoryModel,string)
in <0x11a> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:AddRoot (string)
in <0x66> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:LoadConfiguration ()
in <0x3d> Beagle.Daemon.FileSystemQueryable.FileSystemQueryable:Start ()
in <0x22> Beagle.Daemon.Queryable:Start ()
in <0xef> Beagle.Daemon.QueryDriver:Start ()
in <0x1c7> Beagle.Daemon.BeagleDaemon:StartupProcess ()
in <0xffffffffffffff85> (wrapper delegate-invoke) System.MulticastDelegate:invoke_bool ()
in <0x45> IdleProxy:Handler ()
in <0xffffffffaa5cfbe6> (wrapper native-to-managed) IdleProxy:Handler ()
in <0xb> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0xffffffffffffffd0> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x8> Gtk.Application:Run ()
in <0x6d2> Beagle.Daemon.BeagleDaemon:DoMain (string[])
in <0x1c> Beagle.Daemon.BeagleDaemon:Main (string[])
in <0xffffffffc04370bf> (wrapper runtime-invoke) System.Object:runtime_invoke_void_string[] (object,intptr,intptr,intptr)

Native stacktrace:

        mono-beagled(mono_handle_native_sigsegv+0x88) [0x4f1711]
        mono-beagled [0x4c0210]
        /lib64/libpthread.so.0 [0x2aaaab183be0]
        mono-beagled(mono_string_new+0x2a) [0x44ea71]

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum install beagle
2. beagled


Actual Results:  beagled crashes

Expected Results:  beagled starts up without error

Additional info:
Comment 1 Dave Jones 2006-01-17 12:07:13 EST

*** This bug has been marked as a duplicate of 177592 ***
Comment 2 Andy Burns 2006-01-19 09:15:44 EST
*** Bug 177749 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.