Bug 1779894 - "text" x-descriptors (both "specDescriptor" and "statusDescriptor") always shows "None" whenever the data is "True".
Summary: "text" x-descriptors (both "specDescriptor" and "statusDescriptor") always sh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1780384 1784870 1789903
TreeView+ depends on / blocked
 
Reported: 2019-12-04 23:09 UTC by Samuel Padgett
Modified: 2020-05-04 11:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the OLM `text` descriptor would display `None` in the OpenShift console for boolean values. The `text` descriptor now correctly displays boolean values.
Clone Of:
: 1780384 (view as bug list)
Environment:
Version: 4.4.0-0.ci-2019-12-04-051457 Cluster ID: 73e38a63-0543-4277-9bd4-018c287764e8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Last Closed: 2020-05-04 11:18:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3655 'None' closed Bug 1779894: Fixed the display issue in operand detail view, when the value of the… 2020-04-27 09:42:31 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:19:07 UTC

Description Samuel Padgett 2019-12-04 23:09:12 UTC
From https://jira.coreos.com/browse/CONSOLE-1926


Got reported this bug with "statusDescriptor".

It is noticed whenever the "text" x-descriptor's value is "True", UI would always render "None" instead of showing the actual content (i.e. "True").

After investigating the issues by Yu Zhao, it is found this issue is reproducible on both "specDescriptor" and  "statusDescriptor".

Reproducible Step:
1. assign "text" x-descriptor for "specDescriptor" or "statusDescriptor" in CSV

2. Actual field value is "True"

3. Operand's details view shows "None" but Operand's YAML shows the field value is "True"

Expected Behavior:
Operand's details view should display as "True" (accurately reflect the actual data).

Comment 2 Yanping Zhang 2019-12-16 07:51:46 UTC
Tested on ocp 4.3 with payload version 4.4.0-0.nightly-2019-12-14-103510, set value with "True" for text x-descriptors in specDescriptors and statusDescriptors, then create instance, check on the instance detail page, the value "True" is correctly set.
        specDescriptors:
          - description: spec  test
            displayName: SSPPEECCTT  TTEESSTT
            path: tteesstt
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'
        statusDescriptors:
          - description: status  test
            displayName: STATUS  TTEESSTT
            path: test
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'

The bug is fixed, so move it to Verified.

Comment 4 errata-xmlrpc 2020-05-04 11:18:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.