Bug 1780384 - "text" x-descriptors (both "specDescriptor" and "statusDescriptor") always shows "None" whenever the data is "True".
Summary: "text" x-descriptors (both "specDescriptor" and "statusDescriptor") always sh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1779894
Blocks: 1784870 1789903
TreeView+ depends on / blocked
 
Reported: 2019-12-05 20:22 UTC by Samuel Padgett
Modified: 2020-01-23 11:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1779894
: 1789903 (view as bug list)
Environment:
Version: 4.4.0-0.ci-2019-12-04-051457 Cluster ID: 73e38a63-0543-4277-9bd4-018c287764e8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Last Closed: 2020-01-23 11:17:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3694 'None' closed [release-4.3] Bug 1780384: Fixed the display issue in operand detail view, when the value of the… 2020-05-29 17:01:01 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:18:08 UTC

Description Samuel Padgett 2019-12-05 20:22:39 UTC
+++ This bug was initially created as a clone of Bug #1779894 +++

From https://jira.coreos.com/browse/CONSOLE-1926


Got reported this bug with "statusDescriptor".

It is noticed whenever the "text" x-descriptor's value is "True", UI would always render "None" instead of showing the actual content (i.e. "True").

After investigating the issues by Yu Zhao, it is found this issue is reproducible on both "specDescriptor" and  "statusDescriptor".

Reproducible Step:
1. assign "text" x-descriptor for "specDescriptor" or "statusDescriptor" in CSV

2. Actual field value is "True"

3. Operand's details view shows "None" but Operand's YAML shows the field value is "True"

Expected Behavior:
Operand's details view should display as "True" (accurately reflect the actual data).

Comment 2 Yanping Zhang 2019-12-10 05:45:12 UTC
Tested on OCP 4.3 with payload 4.3.0-0.nightly-2019-12-09-181855.
Install Couchbase Operator in project, then in CSV add x-descriptor with text value "True" in "specDescriptors" and "statusDescriptors" as below, then create instance, check on detail page, it shows "True" for "Test For Bug" and "Status Test For Bug".
        specDescriptors:
          - description: Test Bug.
            displayName: Test For Bug
            path: cluster.testbug
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'
        statusDescriptors:
          - description: Status Test Bug.
            displayName: Status Test For Bug
            path: cluster.statustestbug
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'

The bug is fixed, so move it to Verified.

Comment 4 errata-xmlrpc 2020-01-23 11:17:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.