Bug 1784870 - Some fields in a Operator's CR overview Tab shows None [NEEDINFO]
Summary: Some fields in a Operator's CR overview Tab shows None
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.z
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1779894 1780384 1789903
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-18 14:41 UTC by Suresh
Modified: 2020-05-29 17:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-13 06:14:02 UTC
Target Upstream Version:
mmariyan: needinfo? (hasha)
mmariyan: needinfo? (hasha)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3921 None closed Bug 1784870: Fix display of boolean values 2020-05-29 16:57:13 UTC
Red Hat Product Errata RHBA-2020:0399 None None None 2020-02-13 06:14:11 UTC

Description Suresh 2019-12-18 14:41:03 UTC
Description of problem:
Trying to deploy IBM block CSI operator. Added below in the status x-descriptors:

This is the description in csv:


          - description: Is the controller ready?
            displayName: Controller Ready
            path: controllerReady
            x-descriptors:
              - 'urn:alm:descriptor:io.kubernetes.phase'
          - description: Is the node ready?
            displayName: Node Ready
            path: nodeReady
            x-descriptors:
              - 'urn:alm:descriptor:io.kubernetes.phase'

The above descriptor is not reflecting the corrrect status. The nodeReady and ControllerReady status are updated in the pod status filed inside the pod definition. 

somehow the descriptor is not referring to the kubernetes status field from the pod definition. 

This is the operator.

https://github.com/IBM/ibm-block-csi-operator

Version-Release number of selected component (if applicable):
4.1.8

Comment 1 Stephen Cuppett 2019-12-18 14:53:44 UTC
Setting to the active development version (4.4) for investigation. Any needed fixes or backports will result in cloned BZs.

Comment 3 Robb Hamilton 2020-01-09 19:05:06 UTC
Hi, Suresh.  I'm having a hard time following the issue as described.  Can you please provide detailed steps on reproducing the bug per the Bugzilla template?

Comment 4 Samuel Padgett 2020-01-09 21:15:02 UTC
The `urn:alm:descriptor:io.kubernetes.phase` requires that the value be a string. The `status.controllerReady` and `status.nodeReady` values for this resource are boolean values. This is why no value is showing up.

`urn:alm:descriptor:io.kubernetes.phase` is not the right descriptor for this field. You should be able to use the `urn:alm:descriptor:text` status descriptor to show the boolean value.

Comment 5 Suresh 2020-01-10 16:11:34 UTC
(In reply to Samuel Padgett from comment #4)
> The `urn:alm:descriptor:io.kubernetes.phase` requires that the value be a
> string. The `status.controllerReady` and `status.nodeReady` values for this
> resource are boolean values. This is why no value is showing up.
> 
> `urn:alm:descriptor:io.kubernetes.phase` is not the right descriptor for
> this field. You should be able to use the `urn:alm:descriptor:text` status
> descriptor to show the boolean value.

It doesn't work. Before using the kubernetess.phase, we tried using the text descriptor:

This was the description in csv:

          - description: Is the controller ready?
            displayName: Controller Ready
            path: controllerReady
            x-descriptors:
              - 'urn:alm:descriptor:text'
          - description: Is the node ready?
            displayName: Node Ready
            path: nodeReady
            x-descriptors:
              - 'urn:alm:descriptor:text'

It always show "none" in the value field no the console. 

To reproduce, we can simply install the ibm-block-csi-operator from the operator hub and then edit the CSV to include above.

Comment 7 shahan 2020-02-04 04:17:50 UTC
Install 3scale operator, add bellow content in its csv:
 specDescriptors:

          - description: spec  test
            displayName: SSPPEECCTT  TTEESSTT
            path: tteesstt
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'
statusDescriptors:

          - description: status  test
            displayName: STATUS  TTEESSTT
            path: test
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'
create APIManager instance, check overview page it will have the new field with value true: 
SSPPEECCTT TTEESSTT
spec test
True
STATUS TTEESSTT
True

4.1.0-0.nightly-2020-02-03-232838

Comment 9 errata-xmlrpc 2020-02-13 06:14:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0399


Note You need to log in before you can comment on or make changes to this bug.