Bug 1787588 - Metrics table rows pagination contains off by one bug
Summary: Metrics table rows pagination contains off by one bug
Keywords:
Status: CLOSED DUPLICATE of bug 1790750
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1787583 1790750
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-03 14:33 UTC by Robb Hamilton
Modified: 2020-01-22 19:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1787583
Environment:
Version: 4.4.0-0.ci-2020-01-02-094552 Cluster ID: bf5bdb08-68bf-4174-804d-bd3a5e0a76d4 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.88 Safari/537.36
Last Closed: 2020-01-22 19:06:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robb Hamilton 2020-01-03 14:33:29 UTC
+++ This bug was initially created as a clone of Bug #1787583 +++

Description of problem: The pagination of the monitoring/query-browser table rows includes a bug where the number of rows displayed is off by one.


Version-Release number of selected component (if applicable): 4.4


How reproducible:  Always


Steps to Reproduce:
1.  Visit monitoring/query-browser and create a query that returns more than 10 rows.
2.  Set the pagination count to 10.
3.  Note the number of rows displayed is 9, not 10.

Actual results:  The number of rows displayed is 1 less than the pagination count when the number of rows is greater than the pagination count.


Expected results:  The number of rows displayed should equal the pagination count when the number of rows is greater than the pagination count.

Comment 1 Robb Hamilton 2020-01-22 19:06:51 UTC

*** This bug has been marked as a duplicate of bug 1790750 ***


Note You need to log in before you can comment on or make changes to this bug.