Bug 1787583 - Metrics table rows pagination contains off by one bug [openshift-4.4]
Summary: Metrics table rows pagination contains off by one bug [openshift-4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1788419
Blocks: 1787588 1790750
TreeView+ depends on / blocked
 
Reported: 2020-01-03 14:20 UTC by Robb Hamilton
Modified: 2020-05-04 11:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1787585 1787588 1790750 (view as bug list)
Environment:
Version: 4.4.0-0.ci-2020-01-02-094552 Cluster ID: bf5bdb08-68bf-4174-804d-bd3a5e0a76d4 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.88 Safari/537.36
Last Closed: 2020-05-04 11:22:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3858 None closed Bug 1787583: Fix off by one bug in metrics rows count 2020-04-22 12:44:38 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:22:40 UTC

Description Robb Hamilton 2020-01-03 14:20:13 UTC
Description of problem: The pagination of the monitoring/query-browser table rows includes a bug where the number of rows displayed is off by one.


Version-Release number of selected component (if applicable): 4.4


How reproducible:  Always


Steps to Reproduce:
1.  Visit monitoring/query-browser and create a query that returns more than 10 rows.
2.  Set the pagination count to 10.
3.  Note the number of rows displayed is 9, not 10.

Actual results:  The number of rows displayed is 1 less than the pagination count when the number of rows is greater than the pagination count.


Expected results:  The number of rows displayed should equal the pagination count when the number of rows is greater than the pagination count.

Comment 3 shahan 2020-01-13 03:30:22 UTC
When set the pagination is 10, the actual items nums is 10
4.4.0-0.nightly-2020-01-12-221811

Comment 5 errata-xmlrpc 2020-05-04 11:22:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.