Bug 1789453 - Cannot install freecad 0.18.4
Summary: Cannot install freecad 0.18.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1789866 1790985 1794706 1795057 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-09 15:37 UTC by Josh Cogliati
Modified: 2020-01-28 08:39 UTC (History)
9 users (show)

Fixed In Version: freecad-0.18.4-5.fc30 freecad-0.18.4-5.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-26 01:00:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Josh Cogliati 2020-01-09 15:37:29 UTC
Description of problem:
dnf cannot install freecad 0.18.4

Version-Release number of selected component (if applicable):
freecad             x86_64        1:0.18.4-3.fc31

How reproducible:
dnf install freecad
Last metadata expiration check: 0:00:17 ago on Thu 09 Jan 2020 08:33:34 AM MST.
Dependencies resolved.

 Problem: cannot install the best candidate for the job
  - nothing provides libpyside2.cpython-37m-x86_64-linux-gnu.so.5.12()(64bit) needed by freecad-1:0.18.4-3.fc31.x86_64
  - nothing provides libshiboken2.cpython-37m-x86_64-linux-gnu.so.5.12()(64bit) needed by freecad-1:0.18.4-3.fc31.x86_64
================================================================================
 Package             Architecture  Version                 Repository      Size
================================================================================
Installing:
 freecad             x86_64        1:0.18.3-2.fc31         fedora          38 M
Installing dependencies:
 freecad-data        noarch        1:0.18.3-2.fc31         fedora         169 M
 qt-assistant        x86_64        1:4.8.7-50.fc31         fedora         622 k
Skipping packages with broken dependencies:
 freecad             x86_64        1:0.18.4-3.fc31         updates         31 M

Transaction Summary
================================================================================
Install  3 Packages
Skip     1 Package

Total download size: 208 M
Installed size: 394 M
Is this ok [y/N]: n
Operation aborted.


Steps to Reproduce:
1. dnf install freecad
2.
3.

Actual results:


Expected results:


Additional info:
It will install the 0.18.3-2 version.

Comment 1 Fedora Update System 2020-01-10 01:43:17 UTC
freecad-0.18.4-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-55efa6ebfa

Comment 2 Richard Shaw 2020-01-10 15:32:16 UTC
*** Bug 1789866 has been marked as a duplicate of this bug. ***

Comment 3 Josh Cogliati 2020-01-10 15:37:19 UTC
I appreciate your maintaining FreeCAD and also trying to fix this bug, but right now 0.18.3-2 is more functional until bug 1788682 gets fixed.

Comment 4 Richard Shaw 2020-01-14 19:43:42 UTC
*** Bug 1790985 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2020-01-17 14:23:56 UTC
FEDORA-2020-6840f47e41 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6840f47e41

Comment 6 Fedora Update System 2020-01-17 14:23:58 UTC
FEDORA-2020-bb7ff34fc3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb7ff34fc3

Comment 7 Fedora Update System 2020-01-18 01:25:32 UTC
freecad-0.18.4-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6840f47e41

Comment 8 Fedora Update System 2020-01-18 01:44:19 UTC
freecad-0.18.4-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb7ff34fc3

Comment 9 Richard Shaw 2020-01-24 16:35:53 UTC
*** Bug 1794706 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2020-01-26 01:00:32 UTC
freecad-0.18.4-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Richard Shaw 2020-01-26 18:54:41 UTC
*** Bug 1795057 has been marked as a duplicate of this bug. ***

Comment 12 Peter Larsen 2020-01-26 18:58:20 UTC
Enabling updates-testing resolves the issue. "fix works".

Comment 13 Fedora Update System 2020-01-27 11:26:02 UTC
freecad-0.18.4-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 René Perdok 2020-01-28 08:36:16 UTC
Update is fixed, but now I got a previous problem back, when starting a new or opening an existing file, FreeCAD crashes immediately:

FreeCAD: gl.cpp:2344: const cc_glglue* cc_glglue_instance(int): Assertion `current_ctx && "Must have a current GL context when instantiating cc_glglue!! (Note: if you are using an old Mesa GL version, set the environment variable COIN_GL_NO_CURRENT_CONTEXT_CHECK to get around what may be a Mesa bug.)"' failed.
Aborted (core dumped)


When I run with sudo, there is no problem.

Comment 15 René Perdok 2020-01-28 08:39:54 UTC
It is i bit similar like this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1768480
But this time no segmentation fault but a core dump


Note You need to log in before you can comment on or make changes to this bug.