Bug 1791318 - OpenShift Container Platform installation fails with "could not retrieve networking extension aliases" on OpenStack
Summary: OpenShift Container Platform installation fails with "could not retrieve netw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: rdobosz
QA Contact: David Sanz
URL:
Whiteboard:
: 1830357 (view as bug list)
Depends On:
Blocks: 1828632 1832978
TreeView+ depends on / blocked
 
Reported: 2020-01-15 14:08 UTC by Christian Koep
Modified: 2020-05-07 14:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1828632 1832978 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:24:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3063 None closed Bug 1791318: Don't fail on unavailable features on OpenStack. 2020-06-28 07:26:52 UTC
Red Hat Knowledge Base (Solution) 4736151 None None None 2020-01-15 14:11:34 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:25:16 UTC

Description Christian Koep 2020-01-15 14:08:52 UTC
Dear all,

when installing OpenShift Container Platform 4.2 on OpenStack, the installer exits hard with the following error:

~~~
$ ./openshift-install create ignition-configs --dir=foo --log-level=debug
DEBUG OpenShift Installer v4.2.13
DEBUG Built from commit 46f909e4ccb4f7a4f82bf1ee28b32fa011a6bd1f
DEBUG Fetching "Kubeconfig Admin Client"...
DEBUG Loading "Kubeconfig Admin Client"...
DEBUG   Loading "Certificate (admin-kubeconfig-client)"...
DEBUG     Loading "Certificate (admin-kubeconfig-signer)"...
DEBUG   Loading "Certificate (kube-apiserver-complete-server-ca-bundle)"...
DEBUG     Loading "Certificate (kube-apiserver-localhost-ca-bundle)"...
DEBUG       Loading "Certificate (kube-apiserver-localhost-signer)"...
DEBUG     Loading "Certificate (kube-apiserver-service-network-ca-bundle)"...
DEBUG       Loading "Certificate (kube-apiserver-service-network-signer)"...
DEBUG     Loading "Certificate (kube-apiserver-lb-ca-bundle)"...
DEBUG       Loading "Certificate (kube-apiserver-lb-signer)"...
DEBUG   Loading "Install Config"...
DEBUG     Loading "SSH Key"...
DEBUG     Loading "Base Domain"...
DEBUG       Loading "Platform"...
DEBUG     Loading "Cluster Name"...
DEBUG       Loading "Base Domain"...
DEBUG     Loading "Pull Secret"...
DEBUG     Loading "Platform"...
FATAL failed to fetch Kubeconfig Admin Client: failed to load asset "Install Config": invalid "install-config.yaml" file: platform.openstack.trunkSupport: Internal error: could not retrieve networking extension aliases
~~~

We can see that this fails because the installer can't contact the necessary OpenStack endpoints:

~~~
$ openstack extension list --os-cloud otc
Extensions list not supported by Identity API
Extensions list not supported by Compute API
Failed to retrieve extensions list from Network API
~~~

Can we possibly make the installer show a warning when it can't check for trunks and for octavia as opposed to exiting hard?

Comment 1 Ramon Acedo 2020-01-15 15:13:13 UTC
Please, note that OCP 4.2 has only been tested and is supported on OSP 13 and OSP 15.

Comment 3 David Sanz 2020-02-18 15:16:04 UTC
Verified on 4.4.0-0.nightly-2020-02-18-140650

Comment 5 errata-xmlrpc 2020-05-04 11:24:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581

Comment 6 Martin André 2020-05-07 14:52:33 UTC
*** Bug 1830357 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.