Bug 179309 - gai-pal doesn't build under current devel/fc5 mock due to missing BR
gai-pal doesn't build under current devel/fc5 mock due to missing BR
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gai-pal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On: 179411
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-01-29 23:56 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-12 16:38:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 23:56:15 EST
Description of problem:
gai-pal doesn't build under current devel/fc5 mock due to missing BR

End of the build.log from mock: 

gcc -o gai-pal gai-pal.o  -pthread -Wl,--export-dynamic -lgai -lpanel-applet-2
-lgtkglext-x11-1.0 -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnome-keyring -lxml2
-lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgnomevfs-2
-lbonobo-2 -lgconf-2 -lbonobo-activation -lORBit-2 -lgthread-2.0
-lgdkglext-x11-1.0 -lGLU -lGL -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
-lgmodule-2.0 -ldl -lglib-2.0     -L/usr/lib -lxosd -lpthread -lXext -lX11
-lXinerama
/usr/bin/ld: cannot find -lGLU
collect2: ld returned 1 exit status
make: *** [gai-pal] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.45398 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.45398 (%build)

Perhaps missing a BuildRequires on mesa-libGLU?
Comment 1 Michel Alexandre Salim 2006-01-30 21:09:18 EST
Missing BR is a side-effect of the xorg revamp - I've fixed gai to now BR on
mesa-libGLU-devel, and gai-devel to require it. Both gai and gai-pal will be
pushed into the tree once I could get gai-pal to compile - gtkglext is unhappy
right now.

Thanks for noticing the brokenness,

- Michel
Comment 2 Michel Alexandre Salim 2006-02-12 16:38:00 EST
Version-bumped gai-pal committed; I'll start a rebuild once the rebuilt gai is
in the repository
Comment 3 Michael Schwendt 2006-02-13 20:01:29 EST
The fix is incorrect, IMO. See bug 181018. You should not BR any Mesa
packages and not libGLU-devel either.
Comment 4 Michel Alexandre Salim 2007-01-21 18:42:03 EST
Just noticed this (the bug was not reopened, but I should have checked anyway).
Rebuilding with the dependency taken out now.

Note You need to log in before you can comment on or make changes to this bug.