Bug 179588 - kernel panic when mounting new root fs
Summary: kernel panic when mounting new root fs
Status: CLOSED DUPLICATE of bug 182008
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-01 15:54 UTC by Ronald Warsow
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 16:37:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dig. photo (1.14 MB, image/jpeg)
2006-02-01 16:00 UTC, Ronald Warsow
no flags Details
init from the last running kernel (1.48 KB, text/plain)
2006-02-01 21:58 UTC, Ronald Warsow
no flags Details
init from the kernel panic (1.42 KB, text/plain)
2006-02-01 21:59 UTC, Ronald Warsow
no flags Details
the difference of them: diff init-2.6.15-1.1826.2.10_FC5 init-2.6.15-1.1884_FC5 (163 bytes, text/plain)
2006-02-01 22:01 UTC, Ronald Warsow
no flags Details
diff init's (128 bytes, text/plain)
2006-02-07 12:34 UTC, Ronald Warsow
no flags Details
contents of init directory lib kernel 1909 (59 bytes, text/plain)
2006-02-07 12:35 UTC, Ronald Warsow
no flags Details
contents of init directory lib kernel 1914 (49 bytes, text/plain)
2006-02-07 12:35 UTC, Ronald Warsow
no flags Details
rpm -qpi kernel 1909 (864 bytes, text/plain)
2006-02-07 12:36 UTC, Ronald Warsow
no flags Details
rpm -qpi kernel 1914 (865 bytes, text/plain)
2006-02-07 12:37 UTC, Ronald Warsow
no flags Details

Description Ronald Warsow 2006-02-01 15:54:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
s. attachement and this fstab:

/dev/sda6               /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda3         swap             swap    defaults,pri=-1        0 0
LABEL=SWAP-sda5         swap             swap    defaults,pri=-2        0 0


Version-Release number of selected component (if applicable):
kernel/initrd  2.6.15-1.1884_FC5

How reproducible:
Always

Steps to Reproduce:
1. booting with kernel 2.6.15-1.1884_FC5
2.
3.
  

Actual Results:  reset

Additional info:

Comment 1 Ronald Warsow 2006-02-01 16:00:11 UTC
Created attachment 123967 [details]
dig. photo

Comment 2 Peter Jones 2006-02-01 21:42:51 UTC
So, what were the steps leading up to this?  Is it a new install, an upgrade, or
did you upgrade the package itself?

Is there an older kernel that works?  If so, can you do:

mkdir /tmp/initrd
cd /tmp/initrd
zcat /boot/initrd-2.6.15-1.1884_FC5.img | cpio -di

and then attach /tmp/initrd/init to this bug?

Comment 3 Ronald Warsow 2006-02-01 21:58:11 UTC
Created attachment 123998 [details]
init from the last running kernel

Comment 4 Ronald Warsow 2006-02-01 21:59:08 UTC
Created attachment 123999 [details]
init from the kernel panic

Comment 5 Ronald Warsow 2006-02-01 22:01:30 UTC
Created attachment 124001 [details]
the difference of them: diff init-2.6.15-1.1826.2.10_FC5 init-2.6.15-1.1884_FC5

Comment 6 Ronald Warsow 2006-02-01 22:10:04 UTC
this box was fresh installed at 28.01.2006 to exclude problems with/on my box
after getting problems with each kernel since Version 2.6.15-1.1826.2.10_FC5.

see BUG 179075
this is not testable with that kernel panic now.

Comment 7 Ronald Warsow 2006-02-01 22:12:23 UTC
Comment on attachment 124001 [details]
the difference of them: diff init-2.6.15-1.1826.2.10_FC5 init-2.6.15-1.1884_FC5

LABEL=/12 == /dev/sda6

Comment 8 Peter Jones 2006-02-03 23:17:40 UTC
Where's it getting "/12" from?  What version of mkinitrd are you using?

Can you try rebuilding your initrd with mkinitrd 5.0.20-1 ?

Comment 9 Ronald Warsow 2006-02-04 00:38:43 UTC
/12 came from 2cd installation, anaconda labels the 2cd root partition as /1 or /12.


/dev/sda1 / => my FC4 installation
/dev/sda6 /12 => my FC5-devel installation

BUT is seems, that it is fixed with kernel 2.6.15-1.1898_FC5...

thx !

Comment 10 Ronald Warsow 2006-02-07 12:32:24 UTC
kernel panic back AGAIN !

realizing that kerenel panic comes and goes, my questition:

could it be, that the different kernels are build on different machines from
different developers ?
each time, when kernel panic comes up again, there seems that a module sd_mod.ko
is involved. realizing that over the last 6-8 kernels.

s. attachements

Comment 11 Ronald Warsow 2006-02-07 12:34:03 UTC
Created attachment 124310 [details]
diff init's

Comment 12 Ronald Warsow 2006-02-07 12:35:21 UTC
Created attachment 124311 [details]
contents of init directory lib kernel 1909

Comment 13 Ronald Warsow 2006-02-07 12:35:49 UTC
Created attachment 124312 [details]
contents of init directory lib kernel 1914

Comment 14 Ronald Warsow 2006-02-07 12:36:35 UTC
Created attachment 124313 [details]
rpm -qpi kernel 1909

Comment 15 Ronald Warsow 2006-02-07 12:37:08 UTC
Created attachment 124314 [details]
rpm -qpi kernel 1914

Comment 16 Ronald Warsow 2006-02-14 14:29:04 UTC
after getting the input to build a new initrd with mkinitrd and realizing that a
new kernel installation depends on the contense of (?) modprobe.conf or doing
modprobe sd_mod and then building a new initrd-xxx.img, I was able to help myself.

now I am on kernel-2.6.15-1.1948_FC5 and not excluded from new kernels.
works 4 me !

sorry 4 bad english...

Comment 17 Vladimir Vukicevic 2006-02-25 21:09:26 UTC
I ran into something similar, doing an upgade to FC5t3 from FC4 via the
installer; the initrd created by the kernel installation did not include sd_mod
(on my ata_piix x86 system), so the necessary root/swap devices didn't exist. 
Recreating the initrd image with mkinitrd, expeclitily including a --with option
for sd_mod fixed things.

I'm not sure why it didn't get picked up the first time around -- my previous
kernels were hand-built with ata_piix and the various sd* bits compiled in,
because I was trying to get suspend/hibernate/etc working (with no luck) -- but
I wouldn't have thought that mattered, since sd_mod was clearly loaded by
anaconda and the like.

Comment 18 Peter Jones 2006-02-27 16:37:06 UTC

*** This bug has been marked as a duplicate of 182008 ***


Note You need to log in before you can comment on or make changes to this bug.