Bug 1798613 - Bump image to use ovn2.12
Summary: Bump image to use ovn2.12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Phil Cameron
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1798191 (view as bug list)
Depends On:
Blocks: 1801384 1801417
TreeView+ depends on / blocked
 
Reported: 2020-02-05 16:40 UTC by Phil Cameron
Modified: 2020-05-13 21:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:56:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 72 None closed Bug 1798613: OVN: Bump image to include ovn2.12 2020-05-08 13:41:57 UTC
Github openshift ovn-kubernetes pull 88 None closed Bug 1798613: OVN: ovn2.12 x86_64 build hack 2020-05-08 13:41:57 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:56:21 UTC

Description Phil Cameron 2020-02-05 16:40:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 zhaozhanqi 2020-02-10 03:02:53 UTC
Check this issue on payload 4.4.0-0.nightly-2020-02-09-220310
The ovn is still ovn2.11

rpm -qa | grep -i ovn
ovn2.11-central-2.11.1-24.el7fdp.x86_64
ovn2.11-vtep-2.11.1-24.el7fdp.x86_64
ovn2.11-2.11.1-24.el7fdp.x86_64
ovn2.11-host-2.11.1-24.el7fdp.x86_64

the ovs is using 2.12

rpm -qa | grep -i openvswitch
openvswitch2.12-2.12.0-12.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-14.el7fdp.noarch
openvswitch2.12-devel-2.12.0-12.el7fdp.x86_64

Comment 3 Phil Cameron 2020-03-03 17:48:55 UTC
*** Bug 1798191 has been marked as a duplicate of this bug. ***

Comment 4 Weibin Liang 2020-03-03 18:46:57 UTC
Tested and verified in 4.4.0-0.nightly-2020-03-03-065638

[root@dhcp-41-193 FILE]# oc rsh pod/ovnkube-master-69q68
Defaulting container name to northd.
Use 'oc describe pod/ovnkube-master-69q68 -n openshift-ovn-kubernetes' to see all of the containers in this pod.
sh-4.2# rpm -qa | grep -i ovn
ovn2.12-2.12.0-32.el7fdn.x86_64
ovn2.12-vtep-2.12.0-32.el7fdn.x86_64
ovn2.12-central-2.12.0-32.el7fdn.x86_64
ovn2.12-host-2.12.0-32.el7fdn.x86_64
sh-4.2# rpm -qa | grep -i openvswitch
openvswitch2.12-2.12.0-21.el7fdn.x86_64
openvswitch-selinux-extra-policy-1.0-14.el7fdp.noarch
openvswitch2.12-devel-2.12.0-21.el7fdn.x86_64
sh-4.2# exit
exit
[root@dhcp-41-193 FILE]# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-03-03-065638   True        False         4h35m   Cluster version is 4.4.0-0.nightly-2020-03-03-065638

Comment 6 errata-xmlrpc 2020-05-13 21:56:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.