Bug 1801417 - [4.3]Bump ovnkube to support OVN2.12
Summary: [4.3]Bump ovnkube to support OVN2.12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Phil Cameron
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 1798191 1798613
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 20:20 UTC by Phil Cameron
Modified: 2020-03-24 14:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 14:33:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0858 0 None None None 2020-03-24 14:33:30 UTC

Description Phil Cameron 2020-02-10 20:20:44 UTC
Description of problem:Backport ovn-org/ovn-kubernetes PR 926 to add support for ovn2.12


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Phil Cameron 2020-02-10 21:55:33 UTC
https://github.com/openshift/ovn-kubernetes/pull/86

Comment 3 Weibin Liang 2020-03-04 15:37:09 UTC
Tested and verified in 4.3.0-0.nightly-2020-03-03-144847

[root@dhcp-41-193 FILE]# oc rsh ovnkube-master-8m42g
Defaulting container name to northd.
Use 'oc describe pod/ovnkube-master-8m42g -n openshift-ovn-kubernetes' to see all of the containers in this pod.
sh-4.2# rpm -qa | grep ovn
ovn2.12-2.12.0-32.el7fdn.x86_64
ovn2.12-vtep-2.12.0-32.el7fdn.x86_64
ovn2.12-central-2.12.0-32.el7fdn.x86_64
ovn2.12-host-2.12.0-32.el7fdn.x86_64
sh-4.2# rpm -qa | grep openvswitch
openvswitch2.12-2.12.0-12.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-14.el7fdp.noarch
openvswitch2.12-devel-2.12.0-12.el7fdp.x86_64
sh-4.2# exit
exit
[root@dhcp-41-193 FILE]# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-0.nightly-2020-03-03-144847   True        False         54m     Cluster version is 4.3.0-0.nightly-2020-03-03-144847
[root@dhcp-41-193 FILE]#

Comment 6 errata-xmlrpc 2020-03-24 14:33:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.