Bug 1798925 - KnativeServing link in Global Configuration should use new apiVersion
Summary: KnativeServing link in Global Configuration should use new apiVersion
Keywords:
Status: CLOSED DUPLICATE of bug 1800598
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1798930
TreeView+ depends on / blocked
 
Reported: 2020-02-06 10:43 UTC by Yadan Pei
Modified: 2020-02-10 09:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1798930 (view as bug list)
Environment:
Last Closed: 2020-02-10 09:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
One Obselete and the other one (455.39 KB, image/png)
2020-02-06 10:44 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4250 None closed Bug 1798925: KnativeServing should use new operator.knative.dev apiGroup 2020-06-01 07:22:07 UTC

Description Yadan Pei 2020-02-06 10:43:38 UTC
Description of problem:
KnativeServing link in Global Configuration is using obselete apiVersion which results in a 404 when legacy KnativeServing is not created. 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-05-220946

How reproducible:
Always

Steps to Reproduce:
1. install OpenShift Serverless Operator to all namespaces
2. create knative-serving namespace
3. Create Custom Resource 'Knative Serving' into 'knative-serving' project, a knative-serving instance can be succesfully created
# oc get KnativeServing.operator.knative.dev  -n knative-serving
NAME              VERSION   READY   REASON
knative-serving   0.11.1    False   NotReady
4. Visit Administration -> Cluster Settings -> Global Configuration -> click KnativeServing

Actual results:
4. It reports 404 Not Found https://console-openshift-console.apps.qe-uiyapei44.qe.devcluster.openshift.com/k8s/ns/knative-serving/serving.knative.dev~v1alpha1~KnativeServing/knative-serving

Expected results:
4. The correct URL to get KnativeServing is https://console-openshift-console.apps.qe-uiyapei44.qe.devcluster.openshift.com/k8s/ns/knative-serving/operator.knative.dev~v1alpha1~KnativeServing/knative-serving/yaml.
From OpenShift Serverless Operator, it seems apiVersion serving.knative.dev/v1alpha1 is obselete

Additional info:

Comment 1 Yadan Pei 2020-02-06 10:44:49 UTC
Created attachment 1658138 [details]
One Obselete and the other one

Comment 2 Jakub Hadvig 2020-02-10 09:23:00 UTC

*** This bug has been marked as a duplicate of bug 1800598 ***


Note You need to log in before you can comment on or make changes to this bug.