Bug 1800598 - Update the api group of KnativeServing resources
Summary: Update the api group of KnativeServing resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Ruchir Garg
URL:
Whiteboard:
: 1798925 1798930 (view as bug list)
Depends On:
Blocks: 1798930 1801607
TreeView+ depends on / blocked
 
Reported: 2020-02-07 14:00 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The API group of KnativeServing resources `serving.knative.dev` is deprecated and it has changed to `operator.knative.dev` in Serverless operator 1.4 Consequence: From next release of Serverless operator `serving.knative.dev` will get obsolete. Fix: Changing API group of KnativeServing resources to `operator.knative.dev` Result: Serverless operator continued support for 4.3
Clone Of:
: 1801607 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
Update the api group of KnativeServing resources (91.23 KB, image/png)
2020-02-11 13:04 UTC, spathak@redhat.com
no flags Details
Serverless works fine with the updated api group (55.72 KB, image/png)
2020-02-11 13:06 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4251 None closed Bug 1800598: updates apiGroup for knativeServing resource 2020-06-09 10:07:52 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:11 UTC

Description Jaivardhan Kumar 2020-02-07 14:00:23 UTC
Description of problem:
The API group of KnativeServing resources `serving.knative.dev` is deprecated and it has changed to `operator.knative.dev`.

Version-Release number of selected component (if applicable):4.3


How reproducible: always


Steps to Reproduce:
1. Install OpenShift Serverless operator
2. can see kantiveServing CRD supports two apiGroup

Actual results:
API group of KnativeServing resources `serving.knative.dev`

Expected results:
API group of KnativeServing resources `operator.knative.dev`

Comment 1 Jakub Hadvig 2020-02-10 09:23:00 UTC
*** Bug 1798925 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Hadvig 2020-02-10 09:24:23 UTC
*** Bug 1798930 has been marked as a duplicate of this bug. ***

Comment 4 spathak@redhat.com 2020-02-11 13:04:55 UTC
Created attachment 1662440 [details]
Update the api group of KnativeServing resources

Comment 5 spathak@redhat.com 2020-02-11 13:06:50 UTC
Created attachment 1662441 [details]
Serverless works fine with the updated api group

Comment 6 spathak@redhat.com 2020-02-11 13:07:24 UTC
Verified on build: 4.4.0-0.ci-2020-02-11-035631
Chrome browser: 76.0.3809.132

Comment 8 errata-xmlrpc 2020-05-04 11:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.