Bug 1798930 - KnativeServing link in Global Configuration should use new apiVersion
Summary: KnativeServing link in Global Configuration should use new apiVersion
Keywords:
Status: CLOSED DUPLICATE of bug 1800598
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1798925 1800598 1801607
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-06 10:54 UTC by Yadan Pei
Modified: 2020-02-11 10:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1798925
Environment:
Last Closed: 2020-02-10 09:24:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yadan Pei 2020-02-06 10:54:09 UTC
+++ This bug was initially created as a clone of Bug #1798925 +++

Description of problem:
KnativeServing link in Global Configuration is using obselete apiVersion which results in a 404 when legacy KnativeServing is not created. 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-05-220946

How reproducible:
Always

Steps to Reproduce:
1. install OpenShift Serverless Operator to all namespaces
2. create knative-serving namespace
3. Create Custom Resource 'Knative Serving' into 'knative-serving' project, a knative-serving instance can be succesfully created
# oc get KnativeServing.operator.knative.dev  -n knative-serving
NAME              VERSION   READY   REASON
knative-serving   0.11.1    False   NotReady
4. Visit Administration -> Cluster Settings -> Global Configuration -> click KnativeServing

Actual results:
4. It reports 404 Not Found https://console-openshift-console.apps.qe-uiyapei44.qe.devcluster.openshift.com/k8s/ns/knative-serving/serving.knative.dev~v1alpha1~KnativeServing/knative-serving

Expected results:
4. The correct URL to get KnativeServing is https://console-openshift-console.apps.qe-uiyapei44.qe.devcluster.openshift.com/k8s/ns/knative-serving/operator.knative.dev~v1alpha1~KnativeServing/knative-serving/yaml.
From OpenShift Serverless Operator, it seems apiVersion serving.knative.dev/v1alpha1 is obselete

Additional info:

--- Additional comment from Yadan Pei on 2020-02-06 18:44:49 CST ---

Comment 1 Jakub Hadvig 2020-02-10 09:24:23 UTC

*** This bug has been marked as a duplicate of bug 1800598 ***


Note You need to log in before you can comment on or make changes to this bug.